You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Friday, December 26th 2003, 5:02am

Kopete .7.4 installation trouble

System is running Suse 8.2, with the default 3.1 KDE desktop.

I had Kopete .7.3, supplied by SuSE. Each time I tried to add an account, Kopete crashed (app simply disappeared - no error msg, no lockup).

SO, this evening I first used "rpm -e kopete" to remove .7.3. I then downloaded the tar of Kopete .7.4 from Sourceforge, and tried to install it.

I tar -xvzf'd it in a temporary directory. I then ran ./configure, make, and make install.

It took a short time for me to even find the program file, so maybe I'm just running the wrong executable, but each time I try to launch the program - "/usr/local/kde/bin/kopete", I get many errors, and the window that appears is clearly incomplete, missing menus and menu titles.

The errors include:
kio (KMimeType): WARNING: KServiceType::offers : servicetype Kopete/Plugin not found
kopete: [KopetePlugin* LibraryLoader::loadPlugin(const QString&)] No service implementing the given mimetype and fullfilling the given constraint expression can be found.
kopete: [KopetePlugin* LibraryLoader::loadPlugin(const QString&)] Loading plugin 'aim'failed, KLibLoader reported error:
kopete: [void KopeteAccountManager::save()]
kopete: [virtual LibraryLoader::~LibraryLoader()] All plugins removed



Friday, December 26th 2003, 7:58pm

Two quick things that might help you out in this case.

1.) When you did the ./configure did you add the proper prefix for kde? You can find the proper prefix by typing 'which konqueror' in the console. The output should be something like '/usr/bin/konqueror' or '/opt/kde3' or 'usr/local/bin/konqueror' in which cases your prefix would be respectively '/usr' or '/optkde3' or '/usr/local'. Once you find your prefix go back to the directory you compiled the source in and type 'make distclean' to remove all compiles and configure scripts. Then run ./configure --prefix=prefix/that/I/found

2.) After doing the make install, did you run kbuildsycoca? kbuildsycoca updates kde's plugin base.

9 out of 10 times there is an install error when compiling from source tarball, its the prefix problem. The other time, its kbuildsycoca.


Saturday, December 27th 2003, 2:17am


I'm in WinXP right now, but will try that as soon as I reboot.


Saturday, December 27th 2003, 12:25pm

Your first suggestion, to apply the correct prefix (in my case, /opt/kde3), was the solution.

Thanks again, you were a great help, and spelled out what I needed to do with enough detail and clarity that I was able to do exactly what I needed to with no trouble.

-- Steve