You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.



  • "mae" started this thread

Posts: 1

Location: Pretoria, South Africa

  • Send private message


Friday, April 10th 2009, 5:13pm

[Solved] Huawei E220 wvdial setup.

Hi Friends,

I have found various posts relating to E220 setup with wvdial but none specifically address my error?? received.

The PC in question runs Hardy 8.04

Here is the message recieved when I run "wvdial" in konsole. It looks fine to me but still I cannot connect?

--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Fri Apr 10 16:49:25 2009
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 9078
--> Using interface ppp0
--> pppd: `�[06][08]`�[06][08][10]�[06][08]
--> pppd: `�[06][08]`�[06][08][10]�[06][08]
--> pppd: `�[06][08]`�[06][08][10]�[06][08]
--> pppd: `�[06][08]`�[06][08][10]�[06][08]
--> pppd: `�[06][08]`�[06][08][10]�[06][08]
--> pppd: `�[06][08]`�[06][08][10]�[06][08]
--> Disconnecting at Fri Apr 10 16:50:03 2009
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 160 seconds
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Modem initialized.

I would appreciate any help in this regard......

At last I was able to connect via Huawei E220 modem.

The followings was changes I made.

- Updated Firmware via Web.
- Inserted a new sim card with additional airtime. (I was not sure if the old sim was faulty)
- Installed Ubuntu 9.04, the modem was auto detected, selected service provider and "voila".

I wish this was possible in Kubutu but can not afford to keep on struggling with this issue.

This post has been edited 1 times, last edit by "mae" (May 17th 2009, 12:13pm)