You are not logged in.



  • "GundamGeter" started this thread

Posts: 17

Location: Maryland

Occupation: IT

  • Send private message


Sunday, January 28th 2007, 4:27pm

USB controllers

I have SNES9express loaded and it KDE doesn't recognize the controllers as installed. Does anyone know how to install the controllers, using a keyboards sucks.


Monday, January 29th 2007, 1:03am

SNES9Express is not part of KDE, so i don't expect that you would get an answer to your question.
Better ask the autor of SNES9 for help
Help mee om KDE 3.5.5 in het Nederlands te vertalen


Saturday, March 17th 2007, 1:22pm

I like snes9express and intereste to know the answer too.
however, I guess that keyboard can not replace with controller.

software reviews

This post has been edited 2 times, last edit by "roberts" (Mar 17th 2007, 1:23pm)



Posts: 1

Location: Waterloo, Ontario

Occupation: Studying

  • Send private message


Thursday, April 19th 2007, 4:47pm

I remember having to go through this... KDE has a module to manage joysticks so I guess this is KDE related. My problem was that udev wasn't properly registering my USB joystick. Use Google for some tips... I can't remember how I fixed it.
mmm... I love tasty scons


Saturday, May 19th 2007, 1:05am

Interestingly, and how in environment Gnome is realized?


Friday, June 1st 2007, 6:04pm

I think it's snes9x new joystick handling


First post here. I joined because I noticed this thread and I had just tried fixing up the gamepads in either snes9x itself or in snes9express.

Short: I couldn't fix it.

Long: I searched and read.

That thread apparently was used successfully by someone who gave a link to it from another forum. That poster had been using OpenSusE 10.2 like me, so I tried installing that jscalibrator. I searched for js in YaST Software Management and it was part of one of the packages that came up. I don't remember whether it was an oss, non-oss, Packman, or Suser-Guru source but I installed it.

We using KDE are in luck because we don't need that jscalibrator thing at all. The KDE Control Center provides the same capabilities, as I discovered when running either the jscalibrator and testing or running the Joystick section of KControl gave nearly the same results. Actually the KControl does it better as it doesn't depend upon me (the user) to hit the wrong axis or buttons as long as the automatic settings are detected correctly. I guess if I hit the calibrate button then I would have the chance to mess things up!

The snes9express program has not been updated to work with the changes included in snes9x version 5. I actually couldn't get any games to start up with it, always getting that Error Level 1 message.

Snes9x itself can't seem to find my joysticks so only runs without the joystick. Not too good!

I uninstalled the jscal package as that hadn't done anything to fix the problem, and all my games work fine with my gamepads except for snes9x.

Now for your fix for just getting your USB gamepads recognized. You could manually do

su -
modprobe joydev

but you'd either have to manually edit the file that modprobes stuff to get it to run at every bootup or just do that everytime.

So let's just use SuSE's tools to have the Kernel modprobe joydev at every bootup!

Open YaST. Go to the System tab and the /etc/sysconfig editor.

Go to System, Kernel, MODULES_LOADED_ON_BOOT and type in there


Click finish and restart the computer.

Then go into the KDE Configure Desktop (Personal Settings) and choose Peripherals,Joystick.

Your USB gamepads should be in there and you can test them. There's also a Calibrate button but I haven't needed to bother with that.

One problem I still have is that I have 2 gamepads connected. I want the /dev/input/js0 to be my Thrustmaster Dual-Trigger 2-in-1 Rumble Force and the /dev/input/js1 to be my Wishtec Adaptoid. But depending upon how they are detected at bootup this is sometimes reversed!

So I need to always check in there what order they are in and if it is reversed I have to unplug the second one (the Thrustmaster) and the first one (the Adaptiod) and then plug the Thrustmaster back in (making it the first again) and then the Adaptiod (making it js1 again).

Sometimes this order is the way I want it at bootup and sometimes it's not. But since I tell my games to use the one I want, I always need to check that when KDE loads to see that it's the way I want it so the games will work properly.

I have fceUltraNES, with the GFCE Ultra NES gui program running fine with the gamepads, as well as the Mupen64 N64 emulator. And all native Linux games that use a gamepad detect things fine as well.

Snes9x is a problem and nothing I've found on the net has been of any help. That jscalibrator is great for those using Gnome as Gnome doesn't have that joystick section like KControl does. But it didn't help with snes9x or snes9express.

Yes, I used the calibration tools to point snes9express to the correct /dev/input/ directory, but snes9x or snes9express just cannot use them properly regardless. They calibrate fine within snes9express so it is detecting them properly, but no game can start whether with the GUI or not if I tell it to use a joystick. Games start with the normal snes9x, but do not use the joystick.

So, no need to install jscalibrator for KDE users. KControl does the same thing. The snes9x program is the problem.

As far as zsnes goes, I've had YaST install that and it can never start, period. So I don't even have that installed. Folks over at think zsnes is the greatest but I have no idea how to run it. It just errors out and won't open. And the help or man files for it are not included in the package that I think comes from Suser-Guru. So there isn't even anything to read to try and fix it.

So, I don't play my snes games on Linux. Hopefully someone will explain how these thing s can work at some point.

But hopefully I've helped you at least to get your gamepads running on OpenSuSE. That is supposed to be automatic, but without adding that to the modprobe section at startup, I found that once in a while my gamepad would suddenly show up, then would disappear again! But they are always there if I just add that joydev line to where I told you in YaST.
Epox EP-8KRAIPRO AthlonXP3200+ Crucial 2x512 PC3200 DDRSDRAM 6600GT Audigy 2 ZS Platinum Pro OpenSuSE 10.2


Tuesday, June 5th 2007, 5:54am

Success with zsnes!

I had been using snes9x and noticed that a new version just came out. Since the previous version had been installed using the suser-guru repository, I uninstalled that one and downloaded the new source and compiled myself.

That got as far as make, as make install did not work, complaining about no directory specified and trying to specify did me no good. But it ran about as well as the older one just from the source folder's snes9x executable that make had made. Still no luck with the joystick and reading through all the doc's provided didn't give me a clue what to do to get it to work.

I had remembered that the zsnes that was on the suser-guru repo hadn't even been able to start the program the previous times I had tried it, but I wanted to see what would happen if I compiled it from source so I downloaded version 1.51 of zsnes.

I followed the directions in the html help provided and it even installed perfectly to my system. I needed to have YaST install NASM to get configure to work and make took forever, but it got done and make install worked perfectly.

I just typed zsnes into a terminal and, shockingly, the thing ran perfectly. I made a folder to hold my saves and stuff and set that and the gamepads (detected perfectly!) in the nice GUI options. I just pushed the buttons on the pad and the thing set the pad up.

I set the resolution to 1024x768 (my res on my CRT monitor), set it to full screen, and put my paths in, directed the program to my rom folder when it asked when I pushed the load rom button, and all my roms appeared in the GUI! This thing is great!

Best of all, it runs my games along with great video, sound, and gamepad support.

Guess I'm converted to zsnes. I had always used snes9x in Windows and hadn't even tried zsnes until recently on Linux.

I don't know what's with snes9x and gamepad support, but I just wanted to let you know that zsnes works fine as long as it's compiled for your computer. The precompiled distro version had not run, but letting it compile from the source works great!

You have to do ./configure --enable-release as the directions state. Then it's just make (wait forever) and then su to root and make install. Then just run zsnes (not as root, it didn't need that to go full screen) and set it up how you want in the nice GUI, and play.
Epox EP-8KRAIPRO AthlonXP3200+ Crucial 2x512 PC3200 DDRSDRAM 6600GT Audigy 2 ZS Platinum Pro OpenSuSE 10.2


Wednesday, June 20th 2007, 12:58pm

I would like to know more about SNES9express in detail , as i am a bit unaware .....



Sunday, July 8th 2007, 1:55pm

thanks to all, your advices help me
Janet Kellman, software reviews


Sunday, September 26th 2010, 3:55am

I like snes9express and intereste to know the answer too.

Be happy with funny jokes every day


Thursday, October 28th 2010, 7:59am

Open Host Controller Interface

Open Host Controller Interface

The OHCI standard for USB is similar, but supports USB 1.1 (full and low speeds) only; so as a result its register interface looks completely different. Compared with UHCI, it moves more intelligence into the controller, and thus is accordingly much more efficient; this was part of the motivation for defining it. If a computer provides non-x86 USB 1.1, or x86 USB 1.1 without an Intel or VIA chipset, it probably uses OHCI (e.g. OHCI is common on add-in PCI Cards based on an NEC chipset).

mole mapping


Thursday, November 18th 2010, 12:26pm

Even I like the snes9express and its very interesting.
ipad Accessories, Gadgets


Tuesday, August 27th 2013, 3:50am

Informations de Pack Iphone 5s et des informations sur l'aide pour plus d'informations