You are not logged in.


Sunday, September 12th 2004, 6:11pm

Problems with EPSON Stylus C62 printer.

I'm having trouble with my EPSON Stylus C62 printer.

Here is my netwrok setup:
[list]A) Windows XP (Home Edition)[/list:u]
[list]B) ArkLinux w/KDE[/list:u]
Networked through a router.

I started of having the printer connected to a Windows computer. I set the printer as shared, but when I try to use the Printer Manager to add a printer (SMB), I can click “scan” and the WinXP machine shows up, but I get the following message when I double click on the machine:
[code:1]Error returning browse list: NT_STATUS_ACCESS_DENIED[/code:1]
However, I can network to shared files and folders on that machine without error. After doing a lot of research, I found a few forum posts that said the home edition of XP did not have all the networking support of the professional edition or Win2K, and that has lead to some difficulties with networked printers hosted from WinXP.

So, I figured I would put the printer in the Linux machine and connect to it from the WinXP machine. says this model work perfectly with Linux.

I started by using the "Printing Manager", and it had this model listed, so I figured I am home free. But it does not work. When I print a test page, or any other page, the printer does not do anything, and there are no error messages. Well, the printer worked fine on the WinXP machine, so I know the printer is not broken.

So I figured I would try to use the CUPS web interface (http://localhost:631/admin). But here when I try to configure the printer or add a new printer, the “EPSON Stylus C62” is not listed. If I try to pick something similar, I either get the same result, or the printer does something weird like printing all $ signs (but the fact that it can do that indicated to me that the machine can detect the printer).

I found that on some forums there were people that have specifically said that the gimp-print v4.* did not work for their EPSON Stylus C* printer, and that when they updated to the gimp-print v5 Beta, they were able to get it working. So I tried this too.

So I tried to install gimp-print v5 Beta. But it did not help, so I started a forum point on the ArkLinux site to try to get some help:
They suggested that I not try installing the most recent gimp-print, so I uninstalled it, and reinstalled v4.

But my printer still did not work. But I needed to print some stuff, so I put the printer back on the WinXP machine.

I then noticed in Kynaptic that I had a slightly out of date version of SAMBA. So I upgraded it. Now when I try to use the Printer Manager to network to the WinXP printer from Linux again, when I click “scan” the WinXP machine no longer comes up at all. However, I can still access all the shared files and folders on both machines without error.

Any suggestions would be helpful. Thank you.[/list][/list]



Posts: 115

Location: http://seattle.wa.u$

Occupation: Urban guerilla

  • Send private message


Sunday, September 12th 2004, 7:45pm

The only, and best, way to configure a printer on linux is with CUPS. This is, my opinion of course.

When you visited, it should have a PPD file that you need to download and place on your system (where varies between distros). Also, some printers do require drivers to be downloaded and installed. Just because says there is full support for your printer does not mean it will work right out of the box.

Once CUPS is properly configured, you will also need to configure Samba to share the printer for Windows machines.

I suspect you've just missed a couple of things. Head back to and read all documentation for your printer. Also, visit any printing help pages your particular linux distro may have.

Also, gimp-print is not a requirement for printing. gimp-print is just that.... a printer plugin to be able to print files opened with The Gimp. So unless you're going to be printing from The Gimp, that package is not needed.
-- rm -fr /etc/whitehouse
-- Gentoo | udev | Xorg 6.8.2 | 2.6.14-r4 | KDE 3.5.0


Wednesday, September 15th 2004, 1:49am

OK, I went and I got the PPD file for my printer from gimp-print and put it into my CUPS directory (/usr/share/cups/model/ppd). Then after restarting CUPS service, my printer did show up under CUPS. So I tried adding it agan via CUPS web interface. It added the printer OK, but then wehn I viewed my printers through the CUPS web interface, that printer showed...
Epson Stylus C62 Foomatic/gimp-print (recommended)

Printer State: processing, accepting jobs.
"Connection failed with error NT_STATUS_UNSUCCESSFUL"

OFFICENETWORK is the name of my network, and THOR is the name of the WinXP machine with the printer.

So even CUPS gets the NT error message.

Should I move my printer back to the Linux box, and try it that way?


Wednesday, September 15th 2004, 3:23am

This could be important:
I was just able map to the printer from my laptop (Win2K).

(Sorry I didn't try this before; my laptop has a history of having network problems, so I didn’t think it would work or be helpful).

So, I now have three machines on my network
A) WinXP (printer local)
B) Win2K (Able to map printer)
C) Linux (Gets "Connection failed with error NT_STATUS_UNSUCCESSFUL" error when mapping printer, but able to access files via SMB)



Posts: 115

Location: http://seattle.wa.u$

Occupation: Urban guerilla

  • Send private message


Wednesday, September 15th 2004, 8:14am

You have 2 choices here. Connecting the printer to the linux machine or the windows machine. I would go with linux, but I'm biased.

In any case, IF you choose to go with putting the printer on the linux machine, you'll need to do the following:

1. Physically install the printer to the linux machine
2. Install CUPS
3. Install foomatic (note dependancies)
4. Get PPD file from
5. Install Samba

Before installing samba, make sure you can print locally.
[code:1]# touch test.txt
# echo "Hello World" > test.txt
# cat test.txt > /dev/usb/lp0

Alternatively, for parallel port printers:
# cat test.txt > /dev/lp0 [/code:1]

CUPS does 2 things. I manages your printers and acts as a server to CUPS clients (other linux machines). To allow Windows machines to access it, you need Samba. The following section is sufficient for sharing your printer:[code:1][printers]
comment = All Printer
path = /var/spool/samba
browseable = yes[/code:1]
-- rm -fr /etc/whitehouse
-- Gentoo | udev | Xorg 6.8.2 | 2.6.14-r4 | KDE 3.5.0


Saturday, September 18th 2004, 2:40pm

Sorry it took me so long to respond.

1. Physically install the printer to the linux machine
2. Install CUPS
-- DONE (v1:1.1.20)
3. Install foomatic (note dependancies)
-- DONE (foomatic-db 20040411, foomatic-db-engine v3.0.1, foomatic-db-hpijs 20040311, foomatic-filter v3.0.1)
4. Get PPD file from
-- DONE (I was having trouble finding the downlaodable version online, so I got the PPD file for my printer from gimp-print and put it into my CUPS directory: /usr/share/cups/model/ppd - Is that OK?)
5. Install Samba
-- DONE (v3.0.5)

From Command Prompt:
[code:1]$ touch test.txt
$ echo "Hello World" > test.txt
$ cat test.txt > /dev/lp0
bash: /dev/lp0: Permission denied[/code:1]

If I switch to root user, and run the same thing, the command prompt just hangs there, doing nothing, and does not reprompt me.