You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Friday, June 6th 2003, 8:22pm

X Includes? Problems with themes and ./configure

I'm having some strange issues with installing themes... I'm unable to ./configure any themes. After unpacking the tarbells I run ./configure and meet the same script on each:

"checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!"

I've tinkered with all the --with and --prefix commands but nothing works. My includes are in /usr/X11R6/include and I can't get them to look there. This has also been affecting other runs of ./configure for other applications too.

If anyone has this information, it would be greatly appreciated.
Did you hear a Windows XP installation cd will play satanic messages when you spin it backwards?

That's nothing. When you spin it forwards it installs Windows XP.



Posts: 622

Location: Sydney

Occupation: Student

  • Send private message


Monday, July 7th 2003, 7:33am

perhaps you havent installed the development files?

or try

[code:1]./configure --prefix=/usr[/code:1]

under redhat, and

[code:1]./configure --prefix=/opt[/code:1]
under mandrake (i think)

this basically tells the configure command whereabouts your KDE is installed


Monday, August 25th 2003, 10:09pm

I have same problem too!!

I tried above prefixes... but still the same error ... any clue!!


Tuesday, August 26th 2003, 11:56pm


Come on, doesnt anybody has done this before :(



Posts: 156

Occupation: Engineer

  • Send private message


Wednesday, August 27th 2003, 7:22am

by default the development packages (sources) are not installed. You have to do it yourself. Open you packagemanager and search for something like xfree-devel (or only devel) Install it and it should work.



Wednesday, August 27th 2003, 8:31am

Bad Signature

Bad Signature :roll:
That's what I recieve when I try to add anything from the MDK Disto CDs
what would that be ... ?! :shock:


Wednesday, August 27th 2003, 10:32pm

When I try to compile themes, I get his error:

checking for Qt... configure: error: Qt (>= Qt 3.1.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

I'm running MDK 9.1
"Chopsticks require a person to use 64 muscles and 30 articulate movements simultaneously, which also acts in developing brain potential."



Posts: 622

Location: Sydney

Occupation: Student

  • Send private message


Thursday, August 28th 2003, 6:04am

you need to install the qt-lib and/or the qt-devel files

you can check if you have them though the console:

rpm -q "package_name"


Thursday, August 28th 2003, 8:51am

When compiling for RH9, I always use...

[code:1]./configure --with-qt-dir=/usr/lib/qt-3.1 --prefix=`kde-config --prefix`[/code:1]

Which works every time. But it took several attempts to work this out.



Friday, August 29th 2003, 1:05am

I finally managed to configure things out,
here is what I did.

1. I installed all the qt3 related files
2. I installed all the kde-devel , core files
3. I overcome the bad signature and other CD things by copying the whole RPM files to my HDD and pointed to them as main install using rpm manager
4. voila!!

thanks for all whom helped me out :D



Posts: 622

Location: Sydney

Occupation: Student

  • Send private message


Friday, August 29th 2003, 11:11am

glad it worked out for you :)