You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Wednesday, December 8th 2004, 6:30pm

Same Time Support ??

I see in the description that Lotus Same Time is supposed to be supported but I do not see it as one of the Messaging Services listed. Can someone help me get this working.



Monday, December 13th 2004, 4:08pm

Sametime Support

Gotta bump this one in hopes of someone seeing it. I'm having the same dilemna. I have googled and googled and googled this issue with no success.
Is this a flag in a file that has to be turned on so that the average user isn't presented with options he or she has no use for?

Did the fedora distro strip it out for some reason?

>I see in the description that Lotus Same Time is supposed to be supported but I do not see
>it as one of the Messaging Services listed. Can someone help me get this working.
Caught between the Windows and deep blue sea.


Wednesday, March 23rd 2005, 11:27am

kopete & Sametime


I've got the same problem as well. I read ona Debian list that someone there had the same issue and it was to do with the way the package was created? Basically it was going to be recompiled and support should be there.

I'm running SuSE9.2 Pro and upgraded using the official SuSE RPM's. I would imagine they are using the 'meanwhile' project library but I don't know.

Any light that can be shed on this will be welcome!

If you're having having server problems Ifeel bad for you son,
I got 99 problems but Windoze ain't one!

With apologies to Jay-Z...


Wednesday, April 20th 2005, 10:14pm

Where is Sametime??

Anyone figure out where/how to get Sametime to work?? I see the claims that support
exists, but find it. Thanks.


Monday, May 9th 2005, 3:26pm

RE: Where is Sametime??

im also looking for this sametime support. Did anyone figure out how to make this work? Also, version 0.10 is not avaible to download.


Wednesday, May 11th 2005, 3:12pm

RE: Where is Sametime??

I believe Sametime support is only available in the CVS version. I checked it out (v. 10.90) and built it (no errors! yay!), and now Meanwhile shows up as a protocol in the list. However, I get the following error when I try to connect:
process:13001): meanwhile-CRITICAL **: file srvc_aware.c: line 494 (mwServiceAware_new): assertion `handler != NULL' failed

(process:13001): meanwhile-CRITICAL **: file srvc_aware.c: line 526 (mwAwareList_new): assertion `srvc != NULL' failed
kopete: symbol lookup error: /usr/lib/kde3/ undefined symbol: mwAwareList_setOnAware

So if anyone has any ideas, I would be extremely grateful :-)


Thursday, May 19th 2005, 6:22pm

You need the correct Meanwhile library

After a few compiles of Kopete without Sametime support, I watched the configure script. It said that it could not find the meanwhile libraries, even though I had the latest meanwile libs installed.

Then, on a whim, I installed the older meanwhile libraries (version 0.3) and lo-and-behold, Kopete recognized the libraries and compiled the Sametime support.

So, while I would like to see Kopete use the latest meanwhile libraries, that doesn't seem to be the case. Install version 0.3 of meanwhile, and recompile Kopete.

Unfortunately, when I did this, the gaim-meanwhile (Sametime support for gaim) stopped working...which is why I would like to see Kopete use the latest libraries...I like to have the choice between the two (like today when Kopete won't log into MSN).

This is with the 3.4 gentoo ebuilds for KDE. I don't know if they patched in Sametime support or if it comes standard with 3.4 now.


Friday, May 20th 2005, 2:43pm

RE: You need the correct Meanwhile library

ok but did u pass anything special to configure script in order to point to the right libs (meanwhile 0.3)?

like did u use --with-meanwhile-libs=/blabla and --with-meanwhile-includes=/blabla or that's not necessary?

also: did u get the source for cvs or from kopete site? I tried compiling the cvs version since it comes w/ meanwhile libs already, but even though the meanwhile is enabled in kopete, i'm not able to connect... (haven't checked the stdout errors though).


This post has been edited 1 times, last edit by "ttilt" (May 20th 2005, 2:46pm)


Friday, May 20th 2005, 3:08pm

Nothing special. As a gentoo user, I just emerged the correct packages, which for my system were meanwhile-0.3-r3 and kdenetwork-3.4.0-r2. The Kopete configure script seemed to find the libraries without help.

And no, I didn't do anything from cvs/svn or any other repository other than the released 3.4 tar files used by gentoo.

According to the ebuild script, I don't see that they are applying the sametime patch, and I thought the KDE promo material stated that Sametime was now supported (implying that no special patches were needed for kopete v0.10 to do it).

And, since gentoo by default wants to install meanwhile-0.4.1, I had to override that behavior.

But beyond that, I didn't have give any special parameters to the configure script. In fact, when I had meanwhile 4.1 installed, even passing in the location of the libraries did not must be looking for something in the library routines itself to determine their presence.



Friday, May 20th 2005, 3:25pm

when u say u simply got the package from gentto repository, u mean u got the _source_ package kdenetwork3.4 and compiled it right?


Friday, May 20th 2005, 3:40pm

I believe that's how gentoo ebuilds work. In general, the ebuild scripts download the unmodified sources from a repository, apply any patches, compile and install (gentoo is a source based distribution, not binary RPM based).

So for kdenetwork, the kdenetwork source tarball is downloaded from a gentoo repository, a few patches then get applied to those sources and off it goes.

For instance, kopete patches applied during compilation in the current gentoo ebuild system are as follows:

# fix kde bug 91288 and 105442. Applied for 3.4.1.

# fix kde bug 99671. Applied for 3.4.1.

I expect within a few days there will be another patch added to this list for the current MSN login problem.


Friday, May 20th 2005, 8:02pm

good news,

i used mw 0.3 and it worked. I got the source kdenetwork from kde site, compiled just what i needed (kopete) having compiled and installed mw0.3 first, which made configure script find the libs correctly. So now it's working well.

I'm also having that msn login problem, thought it was a problem w/ msn servers.

This logout patch probably fixes the crash everytime u close kopete?

One problem I noticed w/ the mw plugin is that it doesn't handle accents well from windows sametime or notesbuddy... the accented letters get garbled.

One thing that I really wish mw pluging had besides correct handling of the accents is the ability to get teh contact list from the servers. U also have that problem?


Friday, May 20th 2005, 10:17pm


Originally posted by ttilt

One thing that I really wish mw pluging had besides correct handling of the accents is the ability to get teh contact list from the servers. U also have that problem?

Yes. That is a major hassle. The other hassle is the constant need to use LDAP type terminology to specify sametime contacts (CN=<someone's name>/O=<search domain>), although the meanwhile plugin for gaim has the same problem. The same is true for specifying your account information.

Also, there is no way to change the sametime information after it is entered. The only way I have found is to delete the contact all together and re-add it with the correct sametime account information.

Oh another thing (I keep thinking of them) is that deleting a sametime account strands all the contacts you have entered on that sametime account. When you re-add the sametime account, you must manually add a "sub-contact" to reassociate the contact with the Sametime account. This may be the same for the other protocols, but this is real annoying because of the first problem of not being able to download the contact list from the server.