You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, October 23rd 2003, 1:03am

knetwork 3.2

I am having a problem compiling kdenetwork 3.2 alpha

I get the following error

/bin/sh ../../libtool --silent --mode=link --tag=CXX g++ -Wnon-virtual-dtor -Wno-long -long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BS D_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -Wformat-security -Wmissing-f ormat-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_N O_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -o -rpa th /usr/local/kde/lib -module -avoid-version -L/usr/X11R6/lib -L/usr/local/qt/lib -L/u sr/local/kde/lib kwireless.lo kwirelesswidget.lo linuxwirelesswidget.lo propertytable .lo propertytablebase.lo -liw -lkdeui
/usr/bin/ld: cannot find -liw
collect2: ld returned 1 exit status
make[3]: *** [] Error 1
make[3]: Leaving directory `/home/hibbard/kde/kdenetwork-3.1.92/wifi/kwireless'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/hibbard/kde/kdenetwork-3.1.92/wifi'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/hibbard/kde/kdenetwork-3.1.92'
make: *** [all] Error 2

Any help or insight would be greatly appreciated

Tim Hibbard


Thursday, October 23rd 2003, 9:37pm

Well, I do not know what liblw is, but it seems that you need it.

Have a nice day!


Thursday, February 12th 2004, 9:41pm

same problem with kde 3.2 stable

I'm currently trying to compile KDE 3.2 and get the same error...
...did you solve the problem? I installed some libiw package, but it did not help...

[EDIT:] already solved: installed wireless-tools-26-1