You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Tuesday, January 20th 2004, 12:07pm

Kopete 0.8beta2 - empty config window

Building on Mandrake 9.2, KDE 3.1.3, finally got everything built, but when I start kopete I get a window 'Configure - Kopete' displayed with an empty list on the left hand side and 'Empty page' displayed on the right. Plugins config is also empty. I've created the /etc/kderc file as suggested, listing /usr/local/kde as the prefix, and run kbuildsycoca.

Output from the command line on starting kopete is:


kopete: using X11 MIT Screensaver extension
kopete: [static KSettings::Dispatcher* KSettings::Dispatcher::self()]
kopete: [KSettings::Dispatcher::Dispatcher(QObject*, const char*)]
kopete: [void KSettings::Dispatcher::registerInstance(KInstance*, QObject*, const char*)] kopete
kopete: [static KSettings::Dispatcher* KSettings::Dispatcher::self()]
kopete: [void KSettings::Dispatcher::registerInstance(KInstance*, QObject*, const char*)] kopete
kio (KMimeType): WARNING: KServiceType::offers : servicetype Kopete/Plugin not found
kopete: [KopetePlugin* KopetePluginManager::loadPluginInternal(const QString&)] kopete_chatwindow
kopete: WARNING: [KopetePlugin* KopetePluginManager::loadPluginInternal(const QString&)] Unable to find a plugin named 'kopete_chatwindow'!
kopete: [QValueList<KSharedPtr<KService> > KSettings::Dialog::instanceServices() const]
kopete: calling KServiceGroup::childGroup( kopete )
kopete: [void KSettings::PageNode::sort()] root node
kopete: creating KCMultiDialog
kopete: [static KSettings::Dispatcher* KSettings::Dispatcher::self()]
kopete: [static KSettings::Dispatcher* KSettings::Dispatcher::self()]
kopete: [static KSettings::Dispatcher* KSettings::Dispatcher::self()]
kopete: [void KSettings::PageNode::addToDialog(KCMultiDialog*)] for root node
kopete: [bool KSettings::PageNode::isVisible()] returns false
kopete: [static KSettings::Dispatcher* KSettings::Dispatcher::self()]

I've scanned the last few pages of threads on this forum, and couldn't find anything that helped.

Any suggestions?


Tuesday, January 20th 2004, 2:32pm

same happens on slack 9.1

same with slack 9.1 kde 3.1.4, also recent cvs gives the same prob - last working cvs i think was 0.7.93 or 94, so ive had to go back to 0.7.4 :(


Tuesday, January 20th 2004, 2:36pm


sorry, 0.8 beta's wont even compile, they say that im missing kconfig_compiler during make


Wednesday, January 21st 2004, 8:57am

Heh. I'm doing this because of problems I've been having with 0.74 failing to connect to MSN, so I don't have the option of reverting. Ah well, try another version I guess. Has anyone had any joy at all with recent versions on Mandrake?


Wednesday, January 21st 2004, 9:00am

0.7.5 is out now, get that

but 0.7.4 definately works with msn - im using it right now. have you got openssl installed (does kopete use openssl?)


Wednesday, January 21st 2004, 9:17am

Yes, openssl is installed. I've had MSN working fine with 0.7.4 before, but it's now started failing (won't connect, MSN icon just flashes away merrily). I've tried all the obvious possibilities to no avail (deleting contacts, deleting account etc.) so I decided to kill two birds with one stone and get the latest version installed as well.

0.8rc1 seems to be out now, so I'll give that a go...


Wednesday, January 21st 2004, 11:11am

0.8rc1 compiles and installs flawlessly - but my MSN problem is still there. :( Still can't connect to Yahoo! either.


Wednesday, January 21st 2004, 11:21am

im not sure how yahoo authenticates but i know msn defainately needs ssl, maybe it cant find your SSL binaries, i'l nick some of gaim's FAQ on this for you:

"/usr/lib/mozilla-1.4 to /etc/ and running ldconfig as root *might* fixinate it."

then redo configure ; make ; make install

(the above fix is for a different distro for a different app, but hey, try it)


Wednesday, January 21st 2004, 11:21am

oh ye, replace mozilla-1.4 with you're version of mozilla (leave it 1.4 if thats what uve got obv)


Wednesday, January 21st 2004, 11:29am

The console messages don't seem to suggest that as a problem:

kopete: [void MSNNotifySocket::setStatus(const KopeteOnlineStatus&)] NLN
MNG error 1029: Chunk out of sequence; chunk TERM; subcode 0:0
kdecore (KSocket): ERROR: KExtendedSocket::connectionEvent() called but no data available!

And like I said, MSN worked perfectly well before - I'm just confused that it's given up now without any noticeable changes being made to my setup.


Wednesday, January 21st 2004, 4:17pm

Problem solved - thanks for the help. It was all down to a DNS failure on our intranet. :)


Wednesday, January 21st 2004, 8:28pm

It looks like Kopete's going downhill with this new .8 release...

How did you fix the problem iapetus?


Wednesday, January 21st 2004, 8:32pm

Well, the original problem I fixed by switching to 0.8rc1, which sorted out a couple of compilation problems as well. The second problem I fixed by asking the relevant person to fix our DNS - can't blame kopete for not connecting when won't resolve. ;)


Wednesday, January 21st 2004, 8:35pm

Hum ~ It looks like I still have the same problem only with Oscar. It connects and disconnects immediately after.