You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, April 10th 2003, 6:37am

Browsing problem with KPPP


i've had a couple of issues using kppp with my internet connection.

it seems to work fine, it dials the modem, connects ok, gives me a connected dialog with details
and so forth, but when i open a browser i can't see anything.

if i connect instead by activating the modem from the network device window, it dials my isp,
and all works fine. browsing is no problem from any client, ftp ok and so forth.

i just can't seem to get anything to work using kppp which i would rather use as using the modem
activation process i mentioned above, does not give any info as to the status of the connection,
speed etc (at least i don't know how to access this info when connected like that). all i can get using
kppp is a connection - but thats it!!

any suggestions - even on how to query connection info when using the network device
window - would be most appreciated.

thanks heaps.



Thursday, April 10th 2003, 1:59pm

Have you tried to connect with Kinternet?


Sunday, April 13th 2003, 9:52am


i haven't tried kinternet, though i have read about it, and have since looked to download it but i can not find it anywhere.

no doubt i'm probably looking in the wrong places and i can not seem to find it in my current installation (i am also quite a linux newbie).

i am still looking for it, and i am still looking for a way to solve my current problem with kppp.





Posts: 6

Occupation: Systems Analyst

  • Send private message


Wednesday, April 16th 2003, 7:11pm


If you are using a modem just rewrite your ifcfg-ppp0 and chat-ppp0 (man pppd , man chat, man ifcfg : I believe). After that just give a ifup ppp0 command and see if it dials. If you want to disconnect just do a "ifdown ppp0" and it should bring it down.



Monday, April 21st 2003, 7:51am


thanks for your suggestions.

i did fiddle with the files and it does work fine from the command line. no issues at all.

doing it that way also displayed the modem device as 'active' in the network configuration window.

i do like the features of kppp - i know i'm probably being a little superficial here, but knowing the connection speed, time on line etc. i find quite handy.

if there is any other way to display that sort of data, i'm happy to go with that. at the moment i still can't find a way to display summary info when connected using ifcfg-ppp0.

thanks heaps for the suggestions. any others would also be most appreciated.




Wednesday, April 23rd 2003, 2:00am

I've had the same problem and isolated it further: the problem is related in some way to kppp's ability to properly connect to DNS service. I can consistently reproduce this problem as follows:

1. Start or restart the computer running Red Hat Linux 8, 2.4.18-27.8.0.

2. Use kppp to connect to Earthlink via dial-up. Linux dials out and the connection is established.

3. Open a kterm window and run "/sbin/route -n". Linux displays the route. Note however, that if the "-n" (numeric) is omitted, the route command hangs.

4. In the kterm window, run "vi //etc/resolv.conf". Two DNS servers are listed: These DNS servers are Earthlink's default servers.

At this point, I've repeatedly verified that "ping" can reach network resources by IP address but not by symbolic URL. DNS service isn't properly connected.

5. Disconnect the kppp-based connection.

Now let's use Gnome to connect.

1. In the kde Start Application menu, choose System Tools | Network Device Control. Ghome displays the Network Device Control dialog box.

2. If one is not already defined, use Configure | Add to add a "neat" dial-up connection of the same number as that used in step 2 at the beginning of this post, then Activate the connection. Linux dials out and the connection is established.

Note that at this point proper DNS functioning is achieved.

3. Verify that the general information about DNS is the same as that received by kpp. Use "vi /etc/resolv.conf" to view the list of known DNSs which should be the same as those seen in step 4, above.

4. Use /sbin/route and ping to verify that symbolic connections are available: DNS service has somehow been made to work by "neat" where it didn't with kppp.

5. Use the connection to view the Internet or retrieve e-mail.

Here's where it gets interesting.

1. Disconnect the "neat" connection. In the kde Start Application menu, choose System Tools | Network Device Control, then Deactivate the device activated in step 2, immediately above.

2. Repeat the kppp connection sequence. At this point kppp receives proper DNS service. This remains true until the next time the computer is restarted at which point kppp can only be "fixed" by yet again using "neat" to connect via dial-up.

If anyone has any additional verification steps that I can perform, please post them here. I'm relatively new to Linux but otherwise understand computer usage in general and can follow instructions. I'd be interested in figuring out:

- Why kppp doesn't want to use DNS even though they're "captured" in the /etc/resolv.conf file at the time of connection

- Why "neat" clears this problem for the remainder of the logged on session

Cheers & hope this helps,.
R. Bruce


Friday, May 2nd 2003, 9:50am

interpreteroer errors

I could only surf web with ip address!,because i don't kown how and where to configurate my pc domain network servers ! I connect internet with lan

a sily bird from china!!!!!!!!!!!!!!!!!!!!!


Sunday, May 11th 2003, 2:55pm

dns servers can be added to /etc/resolv.conf.

Help mee om KDE 3.5.5 in het Nederlands te vertalen