You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Wednesday, October 13th 2004, 8:08pm

Start Compiled KDE 3.3 in Mandrake 10.1 Community

Got KDE 3.3 built, as root, using konstruct in Mandrake 10.1 Community. Have tried modifying path as in the konstruct readme and also looked at references about starting mutliple versions of KDE and have set security to lowest setting. Have not been able to boot into KDE 3.3, Mandrake will only autoboot to 3.2. Any suggestions? TIA


Thursday, October 14th 2004, 9:36am


I've quite the same problem :)

I've build KDE 3.3.1 with konstuct under Mandrake 10.0 with my user profile. So my kde 3.3.1 root is in ~/kde3.3.1.

I've read the readme for konstruct that says :


After installation you have to set some variables allowing your system to find
KDE binaries and libraries and KDE to allow to find its own files, for Bash:

export QTDIR=~/kde3.3.1
export KDEDIR=~/kde3.3.1
export KDEDIRS=~/kde3.3.1

export LD_LIBRARY_PATH=~/kde3.3.1/lib
export PATH=~/kde3.3.1/bin:$PATH

Setting KDEHOME too, e.g. "export KDEHOME=~/.kdetest", will tell KDE to save
your settings to this directory and leave default ~/.kde directory unaffected.

And I've found a post on dot.kde that talks about integration in kdm :


Try this:
Create a file in /etc/X11/wmsession.d/ called 20KDE3.1
and put the following in it:
DESC=The K Desktop Environment
EXEC=/home/(your user name)/bin/startkde
exec /home/(your user name)/bin/startkde
(don't put the lines in it.)

And then, create a file in /usr/bin/ called "startkde3.1" (must exactly match).
next, chmod +x /usr/bin/startkde3.1, so it's executable, then edit it and put in the following:
export PATH=/home/(your user name)/bin/:$PATH
export PATH=(path to Qt)/bin:$PATH
export KDEDIR=/home/(your user name)/
export QTDIR=(path to Qt)
/home/(your user name)/bin/startkde
I forgot: to have kdm apply these changes, do the following command as root:
, and then in kdm, choose "Menu : Restart X Server".

Now, I've these files :
DESC=KDE 3.3.1
exec /home/dumoulin/kde3.3.1/bin/startkde
export QTDIR=~/kde3.3.1
export KDEDIR=~/kde3.3.1
export KDEDIRS=~/kde3.3.1
export LD_LIBRARY_PATH=~/kde3.3.1/lib
export PATH=~/kde3.3.1/bin:$PATH
export KDEHOME=~/.kdetest

I've launched /usr/sbin/fndSession as root after stop the dm service, and then I've restarted the same dm service.

I've now kde3.3.1 in the kdm "session type" menu, and try it :)

But, it don't works well. It uses my standard KDE directory (.kde) and not those for test (.kdetest). And I have errors in ~/.xsession taht refers to my actual KDE (3.2) installation. I deduce that my ENV variables are not correctly recorded.

SO I've tried without kdm.
I've stopped the dm service and tried to launch my script /usr/bin/startkde3.3.1. But it doesn't works, it says "No X found" or something like that.

That's all
An idea ? :D


Friday, October 15th 2004, 5:12am

Starting KDE3.3 Mdk 10.1 CE

No success so far. Found this link . If you have CD4 of 10.1 CE the 3.3 rpm's are on it, however I have been trying to use konstruct. The opt/kde suggestion doesn't seem to apply , there is no opt/kde and running krusader to find kde directories yields many. The main directories seem to be etc/kde, usr/include, usr/lib/kde3, and usr/share which has many subdirectories. May try renaming and symlinking these directories, will have to study this a little more.