You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, April 15th 2004, 5:39pm

Font problem, how to explain this ??

I have recently installed KDE 3.2 on my laptop.

It's impossible for me to have a clean font display in all KDE application.
And with antialiasing it's not beautiful.

It's curious because the font are clean with Mozilla, with any size.

So I have tested some things, following :

- Uninstall ALL rpm fonts packages
- Relaunch KDE, all the fonts displayed are horrible :) EVEN in Mozilla. In the "configure desktop/fonts" menu, approximately 10 fonts remain ( It's normal )
- Install the rpm package XFree86-75dpi-fonts-4.3-29mdk
- Relaunch KDE, the mozilla fonts become clean

So I go to "configure desktop/polices" ( A lot of new fonts appear ) to find in the list the font used by mozilla wich is clean. Impossible to find it, all the font I test are not cleanly displayed.

It's incredible, and with KDE 3.1, I did not have the problem, and I used the Helvetica police.

I believe that KDE doesn't use the xfs server to display fonts as Mosilla does. Thus the same police are not displayed identically with xfs and the KDE engine ??

Best regards
Cyril Haenel
Registered Linux User #332632


Friday, April 16th 2004, 8:40pm

Ok, I answer to my question :-D

I have finally found a solution.

In fact, I have uninstalled all the fonts packages, and make some cleaning in the fonts directories.

After that, I have installed one by one the fonts packages, and relaunch KDE all time.

At a moment, I succedeed to have a clean font in kde ( without antialiasing ), with Helvetica, and 12 for the size.

After, I have installed the "urw-fonts-2.0-11mdk", relaunched KDE, and the fonts becam ugly ( alway Helvetica size 12 )
I have desinstalled this package, relaunched KDE, and the fonts became clean ! ( alway Helvetica size 12 )

This package is used by ghostscript and xdpf, and provide this fonts :


Somebody know how to not use this font by default in KDE ?

I have tried to change the line order of the Section "Files" in XF86Config-4, if there is prority in fonts using, but it's not working :)

A solution is to not install this package but if I open a pdf document with xpf or ghostscript, the document is all blank ! :-D

I have also solved another problem : to have same fonts display with non kde application.

Edit the ~/.gtkrc-2.0 file and put the line :

gtk-font-name = "Helvetica 12"

Cyril Haenel
Registered Linux User #332632