You are not logged in.


Wednesday, April 7th 2004, 10:44pm

question about su

Weird thing happening in Redhat 9, kde3.2.1

1. I Open konsole
2. I'm at bash with my regular username roYal
3. Lets say I type something such as ifconfig, or service. I'll get unknown command.
4. I do su, enter password, now I'm root. I type ifconfig or service and I still get unkown command.

This is weird since I"m su, and it wont work. So i try one more thing, System > More programs > Terminal program - Super User Mode. I then enter the password, and Konsole opens.

I then try ifconfig, now it works. The service command also works.

The main question is, why wont these administrative commands work when I su under normal konsole. Why do I have to open the Konsole in Super User Mode for this to work?


Thursday, April 8th 2004, 3:07am

Use "su -" instead of su.



Posts: 257

Location: Lisbon, Portugal

Occupation: Software Engineer

  • Send private message


Friday, April 9th 2004, 9:09am

Ellaborating on epyon response. The command 'su' gives you super user previledges but mantains the enviroment of the user.
If the - flag is specified, the su command initializes the user environment from the values in the user database and the /etc/environment file.