You are not logged in.


Sunday, February 29th 2004, 5:55pm

[SOLVED] KDM startup failure without error message under ...

Hello Everyone!

I am new to this forum, and actually this is my last resort, since this is the KDE place itself. I am normally an IRIX user (SGI Unix) and have taken an interest in Linux distros too. I am fine working with debian and have recently (tried) to switch to gentoo. The installation itself is no problem. The problem starts with kdm.

Basically the entire base system is installed from GRP (Gentoo Reference Platform) LiveCDs, works like a wonder and coexists with my debian install on the little Sharp Actius PC-A290 laptop (PII 366 MHz, 128 MB RAM, Trident 9525 chip for gfx, max 1024x768x16bpp).

I have had no real trouble configuring the x server either. Startx produces twm with the right resolution etc.

Now, the first time I emerged KDE, I updated the environment, ran kdm, and it just cycled through resolutions and returned to text mode.

I thought this might be down to x (mal)configuration and took my working XF86Config-4 from the debian system and put it into the gentoo system. Result: Startx works fine, a little nicer than before, since the settings are a bit mor optimised in the debian one. Then running kdm just does the same: cycle cycle cycle die. Afterwards starting x again just produces a (correct resolution) black screen with X cursor and nothing else.

No error messages whatsoever.

In the first case, before I copied to XF86Config over, startx after kdm failure would produce a blue screen with a little message that kdeinit was not found. (Well, it doesn't exist...)

I really want to avoid to recompile from source,since this machine is not apt (sic) for that, it would take days to reemerge xfree and kde.

If anyone has any ideas whatsoever, I would really appreciate. Maybe there is an error log I am missing...?

Btw, /etc/X11/Sessions contains kde-3.1.3, rc.conf reflects that too.

Thanks in advance. You guys are my last hope here.


Monday, March 1st 2004, 9:16am

Check in /var/log There should be a log file named kdm.log there. I am not sure if that is the same place where it will be in gentoo though. Also try starting kdm from command line and see if this produces any error messages. We can be of help if you post the log messages or any specific errors u observe. Switch to runlevel 3 before starting kdm from terminal.


Monday, March 1st 2004, 11:24am

Hello and thanks for the reply. I will check the log. I have worked from runlevel 3 and purely from console at the moment anyways, I can get no gfx environment. Starting kdm like that produces no errors (visible ones), but I will check that log. Thanks, I'll get back on this one.


Monday, March 1st 2004, 8:03pm

kdm.log reported failure to load I reemerged libart_lgpl, updated the environment,and it works like a charm. Got two EEs in the log, pex5 and xie not being found, but I don't know what that's about. Apart from that it's working fine.