You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, February 26th 2004, 5:46am

KDE crash?

Greetings everybody.

I was reading around the net about the problems starting up KDE, unfortunately, I must add to that statistic.

i'm using LFS 5.0 and I have compiled KDE 3.2 five times. I always seem to hang just before the splash screen. The latest attempt I got a cool intro chime from KDE but still a nice clean bright grey screen and that's all. Using CTRL-ALT-Backspace I get something about a kicker and DCOP. I've cleaned out the /tmp directory and /user directory of the hidden dirs so many times too.

I've used Konstruct and I have compiled using the CVS of the BLFS book. I can't begin to explain the fustration so far. Any insight is appreciated.

Oh yeah, I forgot to mention. I am also using Qt 3.3.0.

The Wokman.
Make it idiot proof, they'll make a better idiot. ---


Thursday, February 26th 2004, 7:12am

try starting kde from a command line and see when it hangs. it might tell you what process is hanging and if there is any error?


Saturday, February 28th 2004, 7:06am

maybe it is QT?

Hello everyone,

Thank you for the suggestions. It did not reveal much other than kdeinit cannot communicate with the X-server and some wierd precision output.

I was just wondering, could it be my QT library was compiled incorrectly? I compiled KDE 3.1.4 against my QT 3.2.1 and no problems. I change the symlink to the new QT (3.3.0) it dies. Am I safe in assuming that because QT 3.3.0 is "binary" compatible so that KDE 3.1.4 should have worked?

Make it idiot proof, they'll make a better idiot. ---


Saturday, February 28th 2004, 9:44am

I think qt 3.3 is not recommended even for kde 3.2. So there might be problems running kde 3.1.4 with qt 3.3.


Saturday, February 28th 2004, 7:37pm

Ah ha! The solution presents itself.

As was suspected earlier, it was QT 3.3.0 giving all the problems. I compiled a fresh new QT 3.2.3 and voila! It worked... Well actually, I had to recompile KDE 3.2.0 from sources again but it was well worth it. :wink:

So, the moral of the story... DON'T USE QT 3.3.0 just yet.

Thanks campusloop for all your help.

Make it idiot proof, they'll make a better idiot. ---