You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Tuesday, January 27th 2004, 9:09am

Konstruct, libltdl

I try to install 3.2rc1 (on Mandrake 9.1) using Konstruct, but the compilation fails with this message:

make[4]: Entering directory `/home/test/download/konstruct/kde/kdelibs/work/kdelibs-3.1.95/libltdl'
/bin/sh ../libtool --silent --mode=compile cc -DHAVE_CONFIG_H -I. -I. -I.. -I../dcop -I../kio/kssl -DQT_THREAD_SUPPORT -I/home/test/kde3.2-rc/include -I/usr/X11R6/include -I/home/test/kde3.2-rc/include -I/usr/X11R6/include -I/home/test/kde3.2-rc/include -I/usr/X11R6/include -D_REENTRANT -ansi -W -Wall -Wchar-subscripts -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -O2 -I/home/test/kde3.2-rc/include -I/usr/X11R6/include -L/home/test/kde3.2-rc/lib -L/usr/X11R6/lib -O2 -pipe -I/home/test/kde3.2-rc/include -I/usr/X11R6/include -L/home/test/kde3.2-rc/lib -L/usr/X11R6/lib -O2 -pipe -I/home/test/kde3.2-rc/include -I/usr/X11R6/include -L/home/test/kde3.2-rc/lib -L/usr/X11R6/lib -O2 -pipe -Wformat-security -Wmissing-format-attribute -c -o ltdl.lo `test -f 'ltdl.c' || echo './'`ltdl.c
ltdl.c:183: `LTDL_OBJDIR' undeclared here (not in a function)
ltdl.c:269: `malloc' undeclared here (not in a function)
ltdl.c:271: `free' undeclared here (not in a function)

I assumed I needed to install libltdl, but this did not help. I have seen other posts here and there with the same problem, but noone seems to know what is wrong.

Any help would be highly appreciated, I want to try out 3.2. :-)


Tuesday, January 27th 2004, 12:04pm


Friday, January 30th 2004, 4:49pm


I finally got it to compile (a tip to others who may be considering Konstruct: read the README, particularly the section on "Preconditions"...).

For the record, a newer version of autoconf did the trick.

However, now I have another problem: I can't get KDE to start. I get to the boot splash, which says "Setting up interprocess communication" for a while, then it disappears and I am left looking at a background.

I have these things in my .bashrc:

export QTDIR=/home/test/kde3.2-rc
export KDEDIRS=/home/test/kde3.2-rc

export WINDOWMANAGER=/home/test/kde3.2-rc/bin/startkde

export LD_LIBRARY_PATH=/home/test/kde3.2-rc/lib:$QTDIR/lib
export PATH=/home/test/kde3.2-rc/bin:$PATH

export KDEHOME=~/.kdetest

My .xsession-errors file can be found here:

One of the things it says is that it looks like dcopserver is already running and that if I am sure it is not I should remove /home/test/.DCOP_server_localhost__0. I tried that, but that did not seem to help.

I would be very grateful if someone could tell me what is wrong.


Wednesday, February 4th 2004, 1:08pm

konstruct + libltdl

I have MDK 9.2 and tried konstrukt, but have the following error:

What can I do?

/bin/sh ../../admin/mkinstalldirs /opt/kde3.2/bin
/bin/sh ../../libtool --silent --mode=install /usr/bin/install -c -p dcop /opt/kde3.2/bin/dcop
/bin/sh ../../libtool --silent --mode=install /usr/bin/install -c -p dcopfind /opt/kde3.2/bin/dcopfind
/bin/sh ../../libtool --silent --mode=install /usr/bin/install -c -p dcopclient /opt/kde3.2/bin/dcopclient
/bin/sh ../../libtool --silent --mode=install /usr/bin/install -c -p dcopobject /opt/kde3.2/bin/dcopobject
/bin/sh ../../libtool --silent --mode=install /usr/bin/install -c -p dcopref /opt/kde3.2/bin/dcopref
/bin/sh ../../libtool --silent --mode=install /usr/bin/install -c -p dcopstart /opt/kde3.2/bin/dcopstart
/bin/sh ../../libtool --silent --mode=install /usr/bin/install -c -p dcopquit /opt/kde3.2/bin/dcopquit
make[6]: Nothing to be done for `install-data-am'.
make[6]: Leaving directory `/home/bat/Install2/konstruct/kde/kdelibs/work/kdelibs-3.2.0/dcop/client'
make[5]: Leaving directory `/home/bat/Install2/konstruct/kde/kdelibs/work/kdelibs-3.2.0/dcop/client'
make[4]: Leaving directory `/home/bat/Install2/konstruct/kde/kdelibs/work/kdelibs-3.2.0/dcop'
Making install in libltdl
make[4]: Entering directory `/home/bat/Install2/konstruct/kde/kdelibs/work/kdelibs-3.2.0/libltdl'
/bin/sh ../libtool --silent --mode=compile cc -DHAVE_CONFIG_H -I. -I. -I.. -I../dcop -I../kio/kssl -DQT_THREAD_SUPPORT -I/opt/kde3.2/include -I/usr/X11R6/include -I/opt/kde3.2/include -I/usr/X11R6/include -I/opt/kde3.2/include -I/usr/X11R6/include -D_REENTRANT -ansi -W -Wall -Wchar-subscripts -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -O2 -I/opt/kde3.2/include -I/usr/X11R6/include -L/opt/kde3.2/lib -L/usr/X11R6/lib -O2 -pipe -I/opt/kde3.2/include -I/usr/X11R6/include -L/opt/kde3.2/lib -L/usr/X11R6/lib -O2 -pipe -I/opt/kde3.2/include -I/usr/X11R6/include -L/opt/kde3.2/lib -L/usr/X11R6/lib -O2 -pipe -Wformat-security -Wmissing-format-attribute -c -o ltdl.lo `test -f 'ltdl.c' || echo './'`ltdl.c
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[4]: *** [ltdl.lo] Error 1
make[4]: Leaving directory `/home/bat/Install2/konstruct/kde/kdelibs/work/kdelibs-3.2.0/libltdl'
make[3]: *** [install-recursive] Error 1
make[3]: Leaving directory `/home/bat/Install2/konstruct/kde/kdelibs/work/kdelibs-3.2.0'
make[2]: *** [install-work/kdelibs-3.2.0/Makefile] Error 2
make[2]: Leaving directory `/home/bat/Install2/konstruct/kde/kdelibs'
make[1]: *** [dep-../../kde/kdelibs] Error 2
make[1]: Leaving directory `/home/bat/Install2/konstruct/kde/kdebase'
make: *** [dep-../../kde/kdebase] Error 2


Thursday, February 5th 2004, 7:59am

autoconf version?

I'm not sure this is the same problem I had, but try updating your autoconf to version 2.5.X (unless you already have that, of course). At least for me doing that solved the compilation problem. (Apparently, Mandrake comes with a really old version.)


Thursday, February 5th 2004, 12:27pm

No, I removed all versions of autoconf, compiled v 2.59 from source and have the same error...