You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Saturday, September 27th 2003, 11:47pm

KDE won't load on Gentoo 1.4

I've emerged KDE and Xfree, yet when I run xdm I get the KDE splash and then an error message saying it couldn't find kdeinit. When I run startkde I get this output:

xset: unable to open display ""
xset: unable to open display ""
xsetroot: unable to open display ""
startkde: Starting up...
startkde: running kpersonalizer...
Kpersonalizer: Error while loading shared libraries: cannot open shared object file: no such file or directory
kwin: Cannot connect to x server
kdeinit: Error while loading shared libraries: cannot open shared object file: no such file or directory
startkde: Could not start kdeinit. Check your installation.
Ksplash: Cannot connect to X server
Error: Can't open display
Warning: connect() failed, no such file or directory
ksmserver: Cannot connect to x server
Startkde: Shutting down...
Warning: connect() failed, no such file or directory
startkde: Running shut down scripts
startkde: done

Now I have this libfam file in my portage directory, with the ebuild, but if I try to emerge it it doesn't find the file. XFree works. I can load up the screen with the clock and three terminal windows. So I know I have that working fine, it's just KDE keeps botching up.

KDE and Xfree are the only things I emerged after loading up the stable kernel (meaning that there was obviously lots of emerging in order to install the kernel, but one I got text mode up and running those were the only two emerges). So I probably missed something somewhere along the line. Any clues?



Tuesday, October 7th 2003, 6:15pm

Have you tried using KDM instead of XDM to see if that makes a difference ? That could tell us somethings.

You should also try posting on the Gentoo forums.


Tuesday, November 4th 2003, 7:38am

what version of kde did you pull down with emerge

and did you use emerge -p kde or emerge -Dp kde

find out what you are missing for your kde-3.x.x

if you want use emerge -UDf kde that will look for updates and download all your packages first then you can have them all in the portage tree when you decide to emerge kde.
"Microsoft does not innovate. It buys, imitates, or steals. It makes things difficult for software developers, and thus eventually for users."



Posts: 156

Occupation: Engineer

  • Send private message


Tuesday, November 4th 2003, 7:34pm

ich think you didn't configure your X Server. Or if you did it, there is a error in the XF86Config. If you have knoppix, you can use the XF86Config created when you boot with it.



Friday, November 7th 2003, 6:03pm

the goog old fam problem ;)

have you searched the gentoo-forums?…ighlight=libfam

fam is the file alternation monitor
normally kde depends on it, better kdelibs
but i can remember that there have been some issues with installing fam and or apps depending on it
check the gentoo forums