You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Sunday, September 14th 2003, 9:20pm

Can't get kphone 3.12 to compile

Hi, I can't get past ./configure in compiling kphone. It says it can't find a working libXext, so it won't proceed. I have a fully functional install of xfree86 on Redhat 9 and Mandrake 9.0. Any ideas? Thanks!


Monday, September 15th 2003, 6:03am

I would imagine that the problem is, as the configure script says, that libXext is missing. Look for an RPM for RedHat or Mandrake. They are probably easy to find if you paste the name of the missing file into a google search. It's also possible that the library simply isn't being found by your operating system, although this is a bit less likely. If you KNOW that you have LibXext, you may want to man ldconfig.
I write a signature to let you know I care.


Wednesday, September 17th 2003, 10:34pm

Hmmm, still no luck. libXext does exist in /usr/X11R6/lib. I ran ldconfig on /usr. Here's a few lines before the failure:
checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
checking for IceConnectionNumber in -lICE... no
checking for libXext... no
configure: error: We need a working libXext to proceed. Since configure
can't find it itself, we stop here assuming that make wouldn't find
them either.

Any ideas? I also tried kphone 3.11 on both Mandrake and Redhat, with the same problem. Thanks!