You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.



  • "Alex" started this thread

Posts: 4

Location: france

  • Send private message


Thursday, February 27th 2003, 11:41am

Kde is slow like hell - riddle

Hi out there

I recently run into a very confusing problem on my Dell Inspiron
8200 Notebook, running KDE 3.1 on Gentoo 4.1.

At home where my laptop is connected to my home network everything
works just fine and fast. But a soon as I use the Notebook without
a connection to the net, the KDE Desktop gets very slow. For example
starting up "Konsole" or "Konqueror" will take about 30 or 50 seconds
(The Notebook has 512 MB RAM and an Intel 4 Processor).

Not all application are affected by this problem, I observed that all
KDE-application and some QT-application are slowed down like this.
But others like Mozilla. OpenOffice or Netbeans work just fine.

Until now I figured out the following things:

When I shutdown all network interfaces (eth0,eth1 and eth2) everything works all right but as soon as there is a network interface up the problem occurs again. The Only network interface which does not affect this is the "lo" (localhost).

When I start a KDE-application from a plain Xsession (no KDesktop) using xterm the problem does not arise even if all network interfaces are up and running.

So I guess that it must be some background service, which is used by most
KDE and some QT applications which causes the problem, but I have no idea what exactly it is. Has anybody an idea then please let me know.





Thursday, February 27th 2003, 1:44pm

Have you tried to run 'top' ? If it is a kdeinit that takes all your cpu you may have to run a 'ps aux |grep _PID number_' to find which program that causes your system slowness.

(btw if you don't like konsole programs hit CTRL+Esc)



Thursday, February 27th 2003, 2:32pm

Re: Kde is slow like hell - riddle

Is your localhost listet in you /etc/hosts?
It mus list something like: localhost
Maybe something like this: localhost




Posts: 156

Occupation: Engineer

  • Send private message


Thursday, February 27th 2003, 2:33pm

are your /etc/hosts and /etc/hostname files set up correctly?




  • "Alex" started this thread

Posts: 4

Location: france

  • Send private message


Thursday, February 27th 2003, 3:12pm

Top shows that althoug the application does only startup very slowly no
process is consuming much cpu time or memory. It looks like there
is some Network IO problem and that a process may wait/sleep for IO or response.

localhost is listet correctly in my /etc/hosts it looks like this (please note that I have got two real network interfaces a builtin and my
pcmcia wireless card) localhost # delux # eth0 # eth2

The hostname is set to "delux" but I have also tried to set it to
"localhost" and it still did not work.

Thanks for you help





Thursday, February 27th 2003, 8:00pm

Slow as hell?

Maybe it's a problem with your laptop. I have aFujitsu-Siemens, it's really fast.



Posts: 156

Occupation: Engineer

  • Send private message


Thursday, February 27th 2003, 8:42pm

I think it is a problem with your /etc/resolv.conf where your DNS server are stored. If you have no network connection your computer hast to wait for a timeout before he can continue.
Perhaps you should try to insert your own computer into /etc/resolv.conf



Thursday, April 10th 2003, 1:12pm

Same problem with my Laptop


I just installed a fresh copy of Mandrake 9.1 with KDE 3.1 and had this same problem.

When logged in as a user applications took about 10 seconds to load. If I su'ed to root (sudo or su -) the same applications loaded nearly instantly.

I added the ip address and host name to the dns system and the problems went away... now just to see what happens when I go home and login...

I added both the forward and reverse address btw.
Bjorn Robertsson


Wednesday, April 16th 2003, 9:33am

It sounds like the time-out thing for sure. Had a similar problem when I installed Linux at work. I had enabled the option to get the hostname through the DHCP server, which made KDE slow, since the server never delivered a hostname.
Ofcorse I use windows, how else would I get fresh air into the room?


Thursday, April 17th 2003, 1:01am

me too

I have exactly the same problem, although I have a very unreliable provider instead of a laptop :roll:
anyway, when i'm connected i can use the internet and everything wokrs fine, but as soon as i get disconnected (which could happen any moment now), kde becomes unbearable slow.

now, i'm a real rookie, installed linux (SuSE 8.2) a couple of hours ago. I have absolutely no idea, where to put what in the files you just mentioned. Does anyone know where i can find good tutorials for this kind of stuff?



Tuesday, May 20th 2003, 1:06pm

speaking of that which has been known to kill cats

Out of curiosity - What is the time-out length by default when a DNS request is botched?

I *believe* I am having this same problem (well, I have the same symptoms - but I am not sure it's a derivitive of the same actual problem). My issue is just about as unpredictable... except it happens _very often_ so I'm not completely sure it's the DNS server... even still, I will add myself to resolve.conf

My particular symptoms are the above, except this hang can happen any time. It won't happen unattended as far as I can see... meaning it's not like it just up and crashes (but it could, i havent had it running long enough to tell). When I do something - nothing, or anything - in KDE that somehow triggers that... be it open a file menu and select an option that has a sub menu... or go to a web page... etc... The system will selectively hang. It is fun to watch actually... either everything will become unavailable, or it will slowly go dead in stages... just the task bar, then just anything network related... or, if I try to run the "top" command - it doesn't go... it hangs. If I am able to catch this and ctrl-alt-backspace and by rare luck get out of kdm/X and am dropped to a hostname login: prompt --- when I enter a username (any username), the login just hangs... you all seeing a pattern here? IT HANGS constently.

So far my transition off of Windows onto the OS I'm more at home on hasn't gone as expected. I hope someone can shed some light onto why this is happening... is it the same issue? What should I do to try and narrow down the bug?

- Digital
The DE-Network Corporation


Tuesday, May 20th 2003, 2:00pm


The timeout on DHCP is 10 seconds. It can be adjusted by adding -tx to the line that calls the daemon. (x being the amount of time to wait.)

Your hangup problem sounds rather like a daemon using all the resources.
Maybe you can find a correlation between what you are doing just prior to the "hang" everytime?


Tuesday, May 20th 2003, 2:33pm

well, I've tried to narrow it down to a trigger... no beans

Firstly - I meant a DNS query, not a DHCP query..

As for narrowing the last action down... I can't say that any particular action or action group has been singled out at all. It happens as root, and as a normal user... happens with much running or little running...

Well, let me give you some background and enviro information

I'm running:
AMD AthlonXP 1800+
1 Gig of Ram
240 Gigs of HD space in the following denominations:
-- 100 gig /dev/hde (two ntfs partitions (40 gig), 4 swap/ext3 partitions (60 gig))
-- 100 gig /dev/hdg (one ntfs)
-- 40 gig /dev/hdh (one ntfs)

nVidia GeForce2 Ultra 64
3Dfx Banshee PCI (in all its lame VESA glory)
3Dfx Voodoo 3 PCI

Gentoo 1.4
KDE 3.1.1a
XFree86 4.3.X
Xinerama mode for use on three monitors, all at the same resolution of 1280x1024
All Xinerama options enabled in KDE (does not affect the hang case)

Input --
Microsoft 'blue' USB optical mouse (/dev/input/mice w/ zAxixMapping and IMPS/2)
Microsoft Natural Keyboard Pro

So far I've been able to hang the system by:

Clicking "Tools" or "Buddies" in gaim and selecting a sub menu *SOMETIMES*
Going to a unresponsive website *SOMETIMES* (made me think DNS)
While screwing around doing normal stuff like opening program menus etc from the K Start menu... etc...

Pretty much anything and nothing triggers it... its completely random in appearance... but im sure there is a root cause. What's strange is... when a process hangs... like when gaim hung, I can't kill -9 it... it just goes HAH IM STILL HERE! and gives me a slightly amused look, followed by another shell prompt as a way of mocking me. Sometimes I will assert my supposed superiority with a "reboot" command or even "shutdown -p now"... but it claims diplomatic immunity (no basis outlined) and refuses to comply... *SOMETIMES*

This is a very wierd hang point that can *sometimes* be waited through... but not usually.

Thanks for all your help!
- Digital
The DE-Network Corporation


Tuesday, May 20th 2003, 2:40pm

Doh, :oops:

Need coffee...., should have reread the post.

You will have to disable things you can (KDE related) and see what help. maybe it is sound related (Do you have sound effects enabled?) disable arts and see if it helps.


Tuesday, May 20th 2003, 2:43pm



Possibly a good call there - I *may have been* running xMMS either streaming from or playing locally of a mounted ntfs drive (is that advisable?) in each case it hung...... but it kept playing through the hang... even if it was streaming. Many things continue working until they too become defunct.... so i don't know :-/
- Digital
The DE-Network Corporation


Tuesday, May 20th 2003, 2:52pm

I run Gentoo(updated weekly for the last year and a half :P ) and I listen to streams all day long, but it could have to do with the specific hardware/software combo's. The sound is just the first thing that came to mind. I would also take out the extra two video cards for a test....


Tuesday, May 20th 2003, 2:59pm


ahh! cant do that! Taking out video cards is not an option :-/ I know that it would help in testing, but right now - I cant afford to lose more time on this than I have... I would prefer to pull the cards out of the config :) ... this box is all big and full of stuff... pulling video cards out is a big dramatic production :-/
- Digital
The DE-Network Corporation


Tuesday, May 20th 2003, 3:02pm

I was trying to eliminate hardware conflicts as well, but failing that just taking them out of the X11 config could help. Try disabling arts first though.


Sunday, June 29th 2003, 11:50am

I had the same problem with my laptop. I have a Mandrake 9.1 installed. My problem is that everytime I launch an application under KDE it takes a lot of time to spawn just doing nothing. If I unplug the ethernet cable it's hell. Every application needs over 10 seconds to be displaied. This is really unbearable. It looks like all my applications need to comunicate with the dns server everytime they start up.

I tried to catch the packets and I found two connections: the first one to the dns server and the second one to the multicast dns (I mean I don't know what these connections are for.

I tried to debug the problem and it looks like this nasty thing is related with the kdmserver. But I'm out of ideas now. I don't know why it had to do a dns request everytime I open an application and I don't know how to prevent this. Once the DNS server had gone down and on my computer was hell. Is this possible?

If you have some ideas please answer this post.

Thank you


Sunday, June 29th 2003, 3:59pm

Ok, I've worked around the problem. It seems that everytime I launch a KDE application it needs to resolve mycomputername address. Why this? I don't know. However it was enough to add the following line to the file /etc/hosts: mycomputername
So everytime it needs to resolve the computer name it no longer ask this to the dns server.
I think, however, that this is a really nasty bug. How could a newbie installing the Mandrake for the first time manage a problem like this? Shouldn't someone correct it?