You are not logged in.


Monday, May 12th 2003, 7:10am

KDE 3.1.1 crashes after desktop configuration is saved.

KDE 3.1.1 crashes after configuration is saved.

Hello friends,
When I saved the actual configuration of the desktop under a certain name, KDE never gets back to a normal operation. Even the start window does not appear again. I see the harddisks operating, sometimes icons appear and disappear, and this is still the case after one hour or so. After stopping the X-server by CTRL-ALT-RET the Login Window appears or even not. Sometimes I get messages like : contact the developer ...
Logging in as a different user (i.e. root) is no problem. I can delete the user, create a new one and it works fine until I try to store or load a desktop configuration. By the way I use Suse 8.2 with the latest patches installed. I have installed the system on a 2nd HD too, but the behaviour is the same.
Any ideas on the problem ? Would like some help.
Christoph (NoFish)


Monday, May 12th 2003, 11:21am

looks like a problem with your home directory.
Is it mounted on a separate partition, or part of / ?

Help mee om KDE 3.5.5 in het Nederlands te vertalen


Monday, May 12th 2003, 11:48am

Is standard installation

Thanks for answering,
No it is a standard installation. This happens with any new user I create. This evening I will make another installation on a separate HD again and try Mandrake 9.1 with KDE3.1.1.

The system crashes after I do something with loading/saving the window design in the configuration manager. It looks more like an endless loop as the HD never stops operating. I will investigate and tell more tomorrow.

But any idea is helpful



Tuesday, May 13th 2003, 6:33am

Yesterday I again installed a new user and tried to produce this "bug" again: success. Every time I want to store or load the "Look and Feel" of the desktop environment, some endless loops start.
Then I switched to console as root and looked with ps x and top what is going on. I found that every 10 sec a new process of kdeadmin started until I had 30 or so running. So I rebooted and when I logged in (as user) the strange behaviour simply continues.
This is with Suse 8.2 / KDE3.1.1.
I tried the same with Mandrake9.1 - All works fine !
Hope that helps ??
Any ideas of what is going on ??


Tuesday, May 13th 2003, 10:01am

From the commandline do
kcmshell -list
Look for the modules LookNFeel/..
Try to start them from the commandline:
[code:1]kcmshell LookNFeel/panel_appearance LookNFeel/icons LookNFeel/kthememgr[/code:1]

All at once, or one by one to figure out which one is causing your problem.

Help mee om KDE 3.5.5 in het Nederlands te vertalen


Tuesday, May 13th 2003, 8:14pm

Do you make any changes to your desktop? If so what?
What happens if you just save the default setup without actually changing anything?


Thursday, May 15th 2003, 12:21pm

So if I create a new user and login everythings is OK. Do nothing else and try to load a Look'nFeel. So you have it ! There is the problem !
In a german newsgoups I have found someone having the same desaster - no solution yet.
Any idea is appreciated.


Thursday, May 15th 2003, 1:35pm

Could this have something to do with language setting?


Friday, May 16th 2003, 5:20am

I checked more yesterday night, but without any usable result:

It is not affected by any language setting. Also happens when saving without any changes made.

Started kcmshell and I get some error code concerning the X server. This seems to be a minor problem, as other programs produce similar messages, but work perfectly.

I have seen that Suse 8.2 uses the /tmp directory for saving settings. I am not sure about what is going on there.

Will continue ...



Thursday, May 29th 2003, 10:53pm

no help, BUT the same issue on my laptop (SUSE8.2, KDE 3.1.1).
Anytime I touch the LOOK&FEEL -> DESIGN tab KDE crashes.
After a crash I can only start KDE after deleting the .kde directory in users home.




Thursday, May 29th 2003, 11:24pm

Some success and explainations...
The situation was, that I want to install a new theme.
After importing the new theme and selecting it, KDE crashes as described above.
After some testing I came to the following result:
Starting the kthememgr from the kcmshell directly and unselecting everything *NOT* touched by the theme let me use the desired theme successfully.

Hope this helps a bit....