You are not logged in.


Tuesday, May 20th 2003, 9:01pm

strange xfree hang issue - possible ide involvement

Hello All,

So far, my gentoo experience has been a bit rocky! I've been impressed with the portage system (FreeBSD background), and have been looking very forward to a full day of work using kde -- but have never been able to pull it off! I'm having some really frustrating problems... maybe you can help?

AMD AthlonXP 1800+
1024 MB RAM
240 HD (100/100/40 - ATA100) (On a High-Point controller, but not in a RAID)
SD Live! (Using Creative Driver)

nVidia GeForce2 Ultra 64 DDR
3Dfx Banshee
3Dfx Voodoo 3

Resolution: 1280x1024x3

/dev/input/mice - zAxisMapping for 4 & 5
microsoft natural pro keyboard

Gentoo 1.4r4/5
XFree86 4.3.0 (Ximania mode)
KDE 3.1.1a


Ok... so the issues:

So far I've done the following to try and narrow the problem down... actually, first: the problem... After either a short time, a long time, or a medium time... my X session will start to deteriorate so-to-speak. Not so much visual anomolies - although there are some (because the hung windows no longer redraw). One by one, and sometimes a few at a time - each window goes zombie in appearance and functionality... but it doesnt always show as such in top/ps.

I've been able to all but remove kde of guilt... I have the issue in straight old xdm... as well as in kdm... and I dont want to go to gnome. I came to Linux for KDE for goodness sake :)

Some strange "properties" of this "hang" problem is - if I am able to open up another konsole or xterm - I will either a) not get a prompt... ever b) not get one for a while or c) get one right away.... but then after I do or don't get a prompt - certain commands will hang... but wont hang the actual terminal "window" meaning... I'll type "top" or "w" or even "ls" ... and it will just sit there like a politician.... but xMMS will keep streaming from just fine... with the equalizer moving even (but was not open during all crashes).

Someone in another forum suggested I run top and see what process was inevitably eating all my CPU and/or RAM - as such providing a clear culprit and a sane <b>immediate</b> solution... well, aside from the fact that once the glitch "triggers" I can't run "top" ... I started top when I started my X session... and left it open. Eventually, I clicked on the "K" start button - and that hung the K toolbar... and didn't show the K start menu.... and it also hung my emerge process for "evolution" (portage "build" reflex)... but gaim was still ok... so I opened an IM to myself, and clicked on one of the file menus...... and it too hung, taking all of gaim with it. And then I moved one of my mozilla windows, and all my mozilla processes hung. Or maybe I just looked at it wierd and it hung... each is possible it seems. Anyway - my open "top" window did _not_ show any rogue processes. gaim and mozilla were kicking it with xmms at pretty much 0 CPU usage... and the highest CPU usage was from X... and nothing to major... like 6-15 at max. I tried killing defunct processes, but only some would die - and those that did only died selectively... killall -9 (or TERM) mozilla-bin would kill 4 of 6 mozilla-bin processes... and killall or kill on anything else didnt work either...

On top of all that - I noticed that 98% of the time, when my system hangs - my HD light is on perpetually... no matter how long I let it think... it never wants to stop thinking. So, in the red glow of my HD LED, I sit there pondering my existence... when I remember that my dmesg output says that idebus is being assumed to be 33, and that I should explicitly set it if it is otherwise.... well it's ATA100! so should I add idebus=100 to my grub.conf kernel line? is that all that's needed for that? will that magically fix the other problem? Do smirfs really exist?

Some stuff I've done to try and solve this...

... I stopped using the "nvidia" driver for my GeForce, and went back to "nv" and disabled "glx" as well..... no beans
... I disabled AGP (fairly sure I did at least)... no beans
... I went down a nVidia-kernel driver version... no beans... but it *does* look crappier... so thats progress I guess... I recompiled my damn kernel with acpi support .. frame buffer support... then i took it out... uh... yeah...

Getting really frustrated with this! Help me out here if you can!
- Digital
The DE-Network Corporation


Wednesday, May 21st 2003, 1:20am

Wierd twist...

Hey again...

I tried some more stuff... I was able to get to the point where I could alt-ctrl-f1 through f6 into terminals... i could log in, but I couldnt run anything... example:

mybox /# ping

Control-C doesnt kill the process... so if I go to each alt-ctrl key and login and type one command... I run out of command consoles and my whole system just sits there calculating pi out to 314234532453452345 digits.

Does that help?
- Digital
The DE-Network Corporation


Wednesday, May 21st 2003, 10:51am

ide resolved

Also... I resolved the IDE issue. Turns out I needed to add support for my VIA IDE controller to my kernel... unfortunately it made no difference :-/
- Digital
The DE-Network Corporation


Wednesday, May 21st 2003, 12:29pm


I'm also unable to login from remote locations. I authenticate fine - but after that it seems unable to load my shell (bash).... and if I login locally, I am able to login completely - but no matter my command, it hangs and i can not regain the console.
- Digital
The DE-Network Corporation


Wednesday, May 21st 2003, 1:09pm

You have been busy....
Have you tried any of the suggestions I made yesteday? (Sound/Video)
In that thread you implied it only happens when using the GUI (KDE). Has this changed?
Are you over clocking your PC?


Wednesday, May 21st 2003, 1:22pm

not blaming kde

nah... im not blaming KDE -- ive pretty much established it has something to do with the kernel possibly...

I was about to yell Eureka when I found that gentoo with the 2.4.20 kernel had a hang error and that it was related to the syslogger in many cases........ problem is I dont run metalog :-/ so it cant be that.

I have been able to crash Xfree86 if I just startx -- not going into kde.... I guess that would rule out audio and video stuff?
- Digital
The DE-Network Corporation


Wednesday, May 21st 2003, 1:42pm

I would not rule out the video stuff /audio does seem to be out of the picture if it will crash with just starting X11.

I know this will sound like a waste of time but change your X11 setup to use framebuffer (just for a test) and run it doing what you normally do - although a lot slower ....


Wednesday, May 21st 2003, 1:48pm


actually, i was going to go in and remove framebuffer support from my kernel... so I'm confused that you would suggest using the fb driver...... but I believe you could be right! The problem seems to be the tdfx driver (among many other possibilities).... whats the procedure to change to use the fb driver?
- Digital
The DE-Network Corporation


Wednesday, May 21st 2003, 4:06pm

Well, you want to leave the FB stuff in the kernel and change your /etc/X11/XF86Config file so that your card driver is set to framebuffer instead of nvidia.


Wednesday, May 21st 2003, 4:08pm

nvidia? Como?

You mean instead of tdfx? I have three cards remember... two drivers. nvidia and tdfx
- Digital
The DE-Network Corporation