You are not logged in.


Saturday, March 15th 2003, 3:29pm

KDE 3.1 on slackware

> Hello,
> I don't know if any of you have installed the kde3.1 on slackware,
> anyway this is my experience, as there isn't a kde3.1 for slackware I
> had to install it from source.
> First I had to donwnload the QT and configure it.
> Then download arts,kdlibs and kdebase, configure, make and make install
> each of them.
> Until here everything is fine, now the kde3.1 works fine. But now I want
> to install other packages that come wiht it like, kdenetwork and
> kdemultimedia.
> When I decompress those packages it says that I should run configure
> make and install. but the fact is that the directory from where to
> configure those packages is not created, the files that are decompressed
> go to different directories like /opt/cd/include or /opt/kde/share/apps.
> My question is from where should I run ./configure for those packages,
> or should I configure again kdbase with those packages decompressed.
> The only information I founded on the net says :
> For each KDE package:
> bunzip2 <package>.tar.bz2
> tar xvf <package>.tar
> cd <package>
> ./configure
> make
> make install
> But as I said decompressing those packages does not create a directory
> with the name of the package.
> Any ideas?



Saturday, March 15th 2003, 4:33pm

Re: KDE 3.1 on slackware

First, what version of Slackware are you using ?
If you are using -current (9.0) Slackware already provides kde-3.1.
If you are using slackware-8.1, you can use the packages on kde's ftp.
It seems that theses packages also works on slackware-8.0

If you are using on older version, you will probably have to upgrade many packages to get kde-3.1 to work.

For your second problem, where did you get your sources tarballs ???
Probably not the officials ones from KDE.


Saturday, March 15th 2003, 6:58pm

I'm using slackware 8.1
In fact kde3.1 is up and running but only because arts, kdelibs and kdebase were configured and make and make install.
That was quite stright forward, my problem is that when I try to install the other packages like kdenetwork and kdemultimedia.

As I read I should do:

To unpack the *.tar.bz2 files, simply run the following two commands for each package:

#bunzip2 packagename.tar.bz2
#tar xvf packagename.tar

Once they are unpacked, simply enter each directory and run the following commands:

#make install

But when I unpack kdenetwork and others there is not a directory form where to run ./configure. Is this normal?

I got my source from the kde page.

Any Ideas? thanks


Saturday, March 15th 2003, 8:03pm

Me again, sort it.
The problem was that I didn't download the proper modules ie: kdesk-3.1.tar I had kdesk-3.1-i386-1.tgz

When I decompress the first the folder was created and the ./configure worked.