You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Friday, September 19th 2008, 1:07pm

compiling KDE from source

Does anybody know if KDE 3.5 can be compiled with qt4? I initially
tried to compile KDE 4.1 but kdepim gives me an error saying there are
no instructions for make after cmake is run. I get this error when
trying to compile KDE 3.5:

checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (library qt-mt) not found. Please check your installation!

For more details about this problem, look at the end of config.log.

Make sure that you have compiled Qt with thread support!

I tried passing --with-qt-libraries and --with-qt-includes to configure with no luck in KDE 3.5

Has anyone had any luck compiling KDE 4.1.1?


Similar threads