You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Tuesday, June 17th 2008, 1:48pm

Cant start documents in KDE from KDE Autostart but can start the programs in Autostart

Hi there
I wonder if you can help me. I am tearing my hair out!
I've created a USB booting Knoppix running KDE and a Persitent Home drive on the pen ( which works).
I want to open two programs: Alsa Modular Synth and Fluidsynth.

These programs start when I run them.
When I put Alsa Modular Synth into Autostart it starts. But if I put a symbolic link to a file saved Alsa Modular Synth it doesn't open the file.

In the same way, Fluidsynth starts when I put the sym link into KDE Autostart, but as soon as I put a soundfont in Autostart (the soundfont is linked to Fluidsynth ) Fluidsynth won't open.

I have tried creating a script but just had no luck.

In windows if you want word to open a word doc on starting up you just copy the shortcut from that word document into startup.....

Why is it when I try to do the same in Linux with KDE the programs won't open with the relevant file?

Thanks for any help - I've spent weeks on this trying to work it out.

I have tried using the KDE session thing but it seems Alsa Modular Synth is not a true KDE compliant program ( ie it doesnt open when the machine reboots if you set the KDE session program to remember the last settings/programs open).

I don't want to confuse things with mentioning Jack....Jack is starting up fine just to let you know.

THanks for any advice or if anyone can point me in other areas to look I would be so obliged. It seems the Knoppix IRC chat channel is dead nowadays...........

I have read all there is about KDE Autostart but things still ain't opening!

Similar threads