You are not logged in.


Saturday, March 15th 2008, 4:46pm

No sound outputs in kmix

Hi there,

I have the following problem with kmix:

after installing a fresh Mandriva2008 with KDE3.5 it shows only INPUT-sliders in kmix. There are no OUTPUT-sliders at all.

I had the same problem when I updated my Suse10.2 to Suse 10.3 and the only solution for me (not a Linux expert but still know to help myself, most of the time) was to reinstall Suse10.2 that worked and sound output in KDE finally did it again.

But now I installed Mandriva2008 because of it`s easy to setup 3D-desktop and now - the sound problem again.
Funny: it seems to have something to do with the KDE-version, because the same problem in Suse (no sound-oututs choosable; just inputs) appeared as soon as I updated it.

Hope anyone finds a solution because I really dont want to switch back to Suse10.2 or use an older kde-version with an older kmix wich would most probably show the output sliders I need and play system-sounds as usual.



This post has been edited 1 times, last edit by "Sascha108" (Mar 15th 2008, 5:33pm)


Monday, March 17th 2008, 6:13am

RE: No sound outputs in kmix

It's always a problem when you modify your windows visuals, sorry, can't help.


Wednesday, March 19th 2008, 6:21am

RE: No sound outputs in kmix


didn't modify my windows visuals. Even tried yesterday evening to install a fresh new and unchanged Mandriva2008 - didn't run any online-updates like before.

I can't modify anything (I just guess your talking about modifying the Tabs in Kmix) my mandriva just doesn't let me set it to the right settings at all: only 4 Input sliders namely INPUT, MICROPHONE, PCM2 and INPUT-AMPLIFICATION.
Kmix still doesn't show me any line or PCM-outs - thats really strange...

I also tried the same version of Mandriva on the laptop of a friend (same KDE of course) and the problem is not there; all two tabs I am missing are there on his laptop and working fine.
He has a noname soundchip called Sigmatel and I have some Realtec in my desktop pc.

I could really live without any lamentation for years without using one of the INPUTS of my soundchip - but the OUTPUTS ... I just need it very badly.

I have the feeling it has something to do with the KDE-version I'm using (3.5) because when I updated my OpenSuse 10.2 to 10.3 I had exacly the same problem, exactly the same sliders and I had to downgrade to Suse10.2 again.

But because the 3D-support (Compiz and friends) is much better for someone who wants to see some desktop-3D-effects without hacking around ones half-lifetime (never got it working under ANY Suse-version at all) I don't reinstall my good old Suse 10.2!

If there's really no other solution, I will try Mandriva-Live-2007.1 CD, and then maybe update some (uncritical) stuff and hope it works better with my soundchip.

Thank you for your respond anyway,