You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Sunday, February 10th 2008, 6:13pm

Scanner only works when Logged in as ROOT

Hi. I haven't used my scanner since upgrading to Kubuntu Gutsy 7.10 with a clean install. I usually use XSane due to it having more options that Kooka. My scanner is a Canon Canoscan Lide60. It has always worked easily under Kubuntu no matter which program I was using. However, when I went to use it last night, XSane did pick up the scanner then shut down. I tried Kooka and it did the same with a KDE crash window. No clue what the cause is. It always worked fine before and I don't think it has anything to do with my scanner due to one odd fact.

That fact is, when logging into the GUI as 'root', both programs pick up the scanner and launch fully. So it sounds like a permissions settings some where. Do I possibly need to chmod some file or add my main login to another group?? I don't know why this would be an issue all of a sudden as it never has been since dapper but regardless, there is a problem. I've often found that there are permission errors causing problems so I have root allowed to login under the GUI so I can check such things out. Sure enough, when logging in as root, everything worked fine with this situation as well.

Any ideas as to what I might need to check, change, and/or fix to solve the problem? I don't want to have to log our of my main id and into root just to use my scanner!!! :o

This post has been edited 1 times, last edit by "myke" (Feb 10th 2008, 11:29pm)


Sunday, February 10th 2008, 11:28pm

I definitely think that it's a permissions error. Unfortunately, as my scanner is connected via usb and not scsi, the permissions error is coming from somewhere else. Here's the output when trying to locate my scanner via "sudo sane-find-scanner"


# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x221c [CanoScan], chip=GL841) at libusb:004:015
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.

So I ran 'sudo scanimage -L' to see if my scanner was detected and it was. This was the output:


device `genesys:libusb:004:015' is a Canon LiDE 60 flatbed scanner

I found a help section (link above) on usb scanners using the genesys backend that notes a problem with permissions but I can't figure out how to fix the problem according to what it says, which is:


The permissions for the device files used by libusb must be adjusted for user access. Otherwise only root can use SANE devices. For Linux, the devices are located in /proc/bus/usb/ or in /dev/bus/usb, if you use udev. There are directories named e.g. "001" (the bus name) containing files "001", "002" etc. (the device files). The right device files can be found out by running scanimage -L as root. Setting permissions with "chmod" is not permanent, however. They will be reset after reboot or replugging the scanner.

According to the output of sudo scanimage -L, the file pertaining to my scanner is located at: /dev/bus/usb/004/015 When I check the permissions of that file, it does note that it belongs to group "scanner" but it is also already set to read/write/execute for owner and group.

In my user group list, I am a member of:


adm, admin audio, cdrom, dialout, dip, floppy, fuse, haldaemon, lpadmin, myke, netdev, operator, plugdev, powerdev, root, saned, scanner, sudo, video

I do believe I have a permissions problem here but I can't figure out which file to fix.

Also of note is that in the file /etc/udev/rules.d/45-libsane.rules, my scanner (canon canoscan lide60) is listed as fully supported. And again, it did work fine up until Gutsy. It was always detected fine. Which it is now as well ... just only when running root under the GUI or via terminal. And that's just a big pain in the backside.



Posts: 3

Location: Belgium

  • Send private message


Monday, May 12th 2008, 9:23am

Possible solution

Hi myke,

I've had the same problems and used some tricks to get by:

1) The simplest way is to just start xsane as root (with sudo) so you don't have to login as root.
2) As chmodding your scanner device (/dev/bus/usb/004/015 in your case) is not permanent, you should write a script for it and place it in ~/.kde/Autostart (just make the permissions least restrictive).

Hope this helps!