You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Monday, September 3rd 2007, 4:46am

Getting KDEtv up and running

Hey, I'm new at this forum, and new to suse in general. I've essentially been bred on a windows environment.
I'm running Suse linux development 10.
I have a TV card:

pcHDTV HD3000 HDTV (the HDTV card found at - but the 3000 version, not the 5000)

Under Video it gives me three options to choose from:
Video4Linux2: pcHDTV HD3000 HDTV
Video4Linux: pcHDTV HD3000 HDTV
XVideo: video4Linux port(275)

I have a coaxil cable hooked up to the tv card.

When I booted up KDEtv with the first option, there was nothing.

When I booted up KDEtv with the second option, it found channels, but when I clicked on those channels, it gave me the prompt, "Unable to grab video.
Video display is not possible with the current plugin configuration. Try playing with the configuration options of the V4L plugin.
----What does this mean?
When I booted up with the third option, it gave me nothing.

When I booted up with the second option, but changed it to the first option after it was booted up, the first option is giving me static, but it looks like the static that I would find on a TV channel that was empty (IE a channel with no TV station broadcasting on it).

Can anyone help me? If you need more information to make a proper judgement, please ask.

Thank you very much in advance.


Tuesday, September 11th 2007, 2:43pm

RE: Getting KDEtv up and running

Bear -

Hmm...I have an entirely different Linux variant (i.e. Debian/MEPIS), and
a different DRIVER (than your HD-thingy).

Yet, when I tried to use KDETV as a TV-viewer, I get the same 3
plugins and the EXACT same error msg as you get.

I have NOT solved this issue yet, either. But, one thing I noticed
in my travels is that I'm using KDETV version 0.8.8, but
that there is a NEWER version (e.g. 0.8.9).

[I don't yet know how to acquire the newer one, but we'd probably have
to 'build from sources', unless we can find a newer binary-kit.]

Post back here, which version of KDETV you are using.

Meanwhile, I'm gonna do some more Googling, and I'll post back here if I
make any breakthroughs.

[There are OTHER tv-viewers, such as 'xawtv' or 'tvtime', but I tried
those also, but neither one worked for me.]

Hope this helps...


This post has been edited 2 times, last edit by "cookdav" (Sep 11th 2007, 6:48pm)


Tuesday, September 11th 2007, 5:58pm

i am running kde 8.8


Tuesday, September 11th 2007, 7:01pm

Ok, I take that you mean you are running v 0.8.8 of KDETV (like me).

[Be careful with version numbers and product names. KDE and KDETV each
have very SEPARATE version numbers. My KDE version number is 3.5.3, and
your KDE version might be (slightly) different than that, but KDE version number
probably doesn't matter.]

There are TWO separate 'about' to show KDE version# and one to show KDETV version#.

(You can just 'edit' your posting if you want to correct this stuff. I'm not criticizing...just
clarifying this stuff, so that others won't be confused.)

I still don't have a solution for our problem. Right now, I do NOT plan to try to get
that newer version of KDETV (version 0.8.9), because I'm unsure whether it will solve
the problem, and 'building from source-code' gets quite tricky. [If YOU want to go
that route, ask someone in your SUSE-support forum how to go about fetching and
building a newer KDETV from source-code. I recommend that, because detailed steps
can be somewhat Linux-distro-specific, and/or someone there may know where you
can get a newer BINARY kit for KDE/KDETV for SuSE.]

Hope this helps...



Monday, September 17th 2007, 3:46pm

I finally got my SABRENT card (card=42) to work, using 'kdetv' (and other tv-viewers).

The KEY think was to make an educated guess (and guess right) at the
'tuner=<nr>' option (in modprobe.conf).

For my SABRENT PCI card, it was 'tuner=69', and then suddenly, all the tv-tuner
programs started working! ['kdetv' is my favorite, and version 0.8.8 works just fine]

It sure would be nice to find some (central) place where someone could explain
what the various values of 'tuner=' map to, and how to determine that correct value
for any given 7134-based card.

Cheers...hope this helps someone else.