You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Friday, August 17th 2007, 5:30pm

KWalletManager - "Binary Data" [SOLVED]

I'm using KWallet to store my passwords. I recently installed Linux on my laptop and migrated my ~/.kde there, and tried to get my old passwords using KWalletManager. But what were once passwords are now stored as "binary data". There is one password in there that for some reason I didn't write down elsewhere, and that I really need to get back. Does anyone have any suggestions on how to get this data back in readable form? I know it was possible before, on an older installation..

Thanks in advance

This post has been edited 1 times, last edit by "Kolja" (Aug 17th 2007, 11:50pm)


Friday, August 17th 2007, 11:49pm

OK, solved the problem.

The password missing was for Kopete. I just ran Kopete first, created a bogus Jabber Account, set a password for that and saved it with KWallet. After that, dragged and dropped my old kwallet.kwl into the manager and opened that second wallet. The old passwords, as well as the new ones, were now shown as passwords and not as binary data anymore.

I guess this works with other applications too, as my Konqueror passwords are shown the same way, but I can't guarantee that.

I hope I could help someone with this, I'm just glad I got my password back.

Good Night