You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Monday, August 13th 2007, 10:59pm

[solved] cmake project setup/use issues

I've been wrestling with cmake on and off for about 3 days now trying to setup a kde4 project to use it. I've attempted to emulate the setup of the kde svn projects but I still seem to be having trouble. Here is my setup: /, /src, /build
Under / I have a CMakeLists.txt:

Source code

find_package(KDE4 REQUIRED)

Under /src I have a CMakeLists.txt:

Source code

kde4_add_executable(projname srcs)
target_link_libraries(projname ${KDE4_KDEUI_LIBS})

/build is empty.

I cd into build and run "cmake ../" then "make" says "no objdir found. Tried /".

Am I just stupid or doing something terribly wrong? I'm only using a single source file which consists of main() with a few qt and kde calls and then an exit; I'm doing this to test and setup and I still can't get it working.

Thanks for the help.

Nevermind, I'm an idiot, I had an old alias (make=makeobj) from when I was setting up stuff to build alpha kde.

This post has been edited 3 times, last edit by "valis" (Aug 17th 2007, 10:34pm)