You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.



  • "ntvuok" started this thread

Posts: 4

Location: Finland

  • Send private message


Monday, May 14th 2007, 7:58pm

Multimedia keys and shortcuts totally weird

At first all my multimedia keys worked fine (at least after I fixed the double assignment of XF86RaiseVolume in config files). Now the situation is this:

- None of the shortcuts I define in the Control Center work: I have tried using "keyboard shortcuts" and "Input actions" (DCOP and commands). Those just DON'T work.

- I can use Amarok global shortcuts with some of my multimedia keys, but Volume keys and Mute DON'T work if I try to assign them to something. Other keys which don't work when assigning them to commands in "keyboard shortcuts" DO work here.

- Using Kmix Global shortcuts DOESN'T work no matter which keys I try to assign here.

I noticed that the keys don't work, if they are used in two different places in KDE. I have disabled all DCOPs and commands in "Input actions" for the duration of my testing and tried to disable any other duplicates. The problem can be that somewhere there is a setting I haven't found, but how can I find it out? I have checked those places mentioned above.

If anyone has an idea to fix this mess OR even an idea how to try to debug this (what logs to check or activate, some kewl hacking, etc.) then please please please say it!
gentoo / 2.6.19-r5
KDE 3.5