You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, February 8th 2007, 9:23pm

Ctrl-C does not kill a process in Konsole

I am using KDE 3.3.1-3.14 Red Hat. The OS was recently upgraded to Red Hat RHEL 4. Platform is Linux x86.

Before the OS upgrade I used to be able to kill a process in the Konsole terminal with Ctrl-C. Now it doesn't work anymore and is really annoying, i.e. I have to go to a separate terminal/tab and hit "kill -9". (I case it helps, the command I use often and I'd like to kill is "tail -f")

I've been stuck with this problem for months now and have not been able to find help online. Therefore, any help is greatly appreciated. Thanks,



Friday, February 9th 2007, 11:06am

does ctrl-c work in other terminals, like xterm, or in a real console, like tty1?
Help mee om KDE 3.5.5 in het Nederlands te vertalen


Friday, February 9th 2007, 7:10pm

Yes, it works on an xterm. Just fails in Konsole.

Yesterday I noticed that I had a Ctrl-C keyboard shortcut for Copy (under Control Panel -> Regional & Accessibility -> Keyboard Shortcuts -> Application Shortcuts). I removed that shortcut, but the problem didn't go away.



Friday, February 9th 2007, 8:27pm

Problem solved: I had configured a Ctrl-C shortcut for copy in Konsole. I removed it, and it works now.

Thanks for the help!