You are not logged in.


Tuesday, January 16th 2007, 12:43am

Mounting USB flash drive

Hi all

I am wondering how to get KDE to automount my USB flash drive when I plug it in. If I plug the stick in before booting, the drive appears on my desktop, and I can use it and safely remove it. However, it is not recognized if I plug it in at anytime post-boot. Is there any way to achieve this? I am using KDE 3.5.5. Thanks.



Tuesday, January 16th 2007, 12:47am

automounting is mostly done by your linux distribution.
What distribution are you using?
Help mee om KDE 3.5.5 in het Nederlands te vertalen


Tuesday, January 16th 2007, 12:49am

I am using Fedora Core 5


Tuesday, January 16th 2007, 1:16am

Have been researching a bit about automounting, and I think it is the HAL daemon that performs the task. I have confirmed that this is running. I have also read that the problem may be caused by weird file system structures on the disk. I have since reformatted the stick with fdisk and mkfs to use vfat. However, still not working.


Tuesday, January 23rd 2007, 11:46am

Have you tried right-clicking on the device on desktop? There should be an option to automount it somewhere


Wednesday, January 24th 2007, 12:46pm

does the stick show up anywhere at all? you might have turned automounting off in the control center as well.
-=| life sucks deeply |=-



Posts: 7

Location: London UK

Occupation: loafer

  • Send private message


Wednesday, March 7th 2007, 10:15am

usb mounting


I have been trying to solve the exact same problem with regards to flash drives for a while now. The 'hal daemon' is indeed responsible for the mounting of external devices. I have a 2gb fairly cheap and nasty mp3 device that has never 'hot plugged'. I know through my research that it is far better to have such a device formatted as fat16 as opposed to fat32. I can't recall why this is but will have another search for you.

I have come across many different elements to the subject of hotplugging devices when searching for an answer to this problem. it confuses the hell out of my humble mind.…otplug-devices/

might help but I am unsure of it's contemporary relevance

Is the closest I have come to finding out what is wrong with my hotplugging. Personally, I imagine it is possibly down to my hardware.
However, when I enter the bios(press f2 when first screen appears) at boot I notice a message which says 'usb device initialized'. Maybe this is overriding any device I choose to plug post-boot? I don't know for sure. I do know that this problem remains for me.

Lastly, have you looked through the output of 'dmesg' after plugging the device? It may tell you something.

Entering 'lsusb' in a terminal will list all of your active usb ports and any devices which are plugged in.If you can see your device after plugging it post-boot with lsusb you are getting somewhere.
I would suggest posting a thread at launchpad if you can't solve this problem through these or any other forum.

good luck

As long as it is linux it's ok