You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, November 9th 2006, 10:05pm

KMail doesn't store password?


since Kubuntu 6.10 / KDE 3.5.5 KMail is unable to store my password. I believe there should be two ways:
1. If one use KWallet it can save the KMail password. Here is the problem that KMail opens up the PW entry dialog for email downloading without asking KWallet to open to get it's information from there.
2. KMail should be able to save it's password by itself but this doesn't work, too. After restarting KDE the entry in the send properties is empty and KMail opens up it's PW entry dialog.

I tried to delete my email account in KMail and recreated it, tried to re-install KMail and Kontact, I tried to delete the KMail entries from KWallet but nothing worked. It seems to me that this is a serious bug in KMail, isn't it?

thanks for help


Saturday, November 18th 2006, 8:39am

Though Kwallet seemed to work fine, it was the reason for all my trouble.
You can find more information about kwallet and not storing passwords here:…tils/+bug/67521

The solution ist:
go to kwalletmanager properties,
deactivate automatic start,
restart KDE
activate atomatic start again.



Friday, March 13th 2009, 7:30pm

I had the same exact issue as described and found that these two files had incorrect ownership:



I had to rename these out of the way to see that when they were re-created, they were now owned by me and not 'root'. And, now I can shut down Kmail and re-start it with both of my accounts working properly.

BTW, I found these files when I did a:


find $HOME -name "*.*" -exec grep {} /dev/null \;
When I saw errors that permissions were denied on these two files and they were binary files I couldn't review, I just renamed them out of the way to preserve them in case something went wrong. Once I launched Kmail, these two files were re-created under my ownership with '6-0-0' permissions.

Hope this helps someone out there!! 8)