You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Saturday, July 8th 2006, 7:03pm

[SOLVED] [Kopete] configuration messed up

I have a really strange problem with my Kopete configuration. I have several different accounts (jabber, MSN and IRC) configured. Whenever I try to delete one of these accounts, it gets re-added when I start Kopete the next time.
I did even remove ~/.kde/share/apps/kopete and ~/.kde/share/config/kopeterc. Then I started Kopete again, and my different accounts were there again. How can this be? How can Kopete "remember" the settings, when I delete the configuration file?

Does anyone have a hint for me?
Kopete works fine for other users, I may also copy my configuration to another user's home folder and start Kopete as this user, works fine then (including removing accounts without them being re-added at next startup).

This post has been edited 1 times, last edit by "bauerfichtner" (Jul 9th 2006, 5:11pm)


Sunday, July 9th 2006, 11:17am

I'm even more confused now. I tried adding an additional account, which worked fine. I closed Kopete and started it again. The account was still there, so I tried to remove it, which worked fine. So, I have three accounts I cannot remove from my configuration, but I may remove any account I add by now.
What could be wrong?


Sunday, July 9th 2006, 5:06pm

Hmm, strange thing, this.
It seems as if Kopete took some configuration from the file ~/.kde/share/config/kdeglobals
I removed the account configuration from this file, after that, I was able to remove the account from Kopete without problems.

Does anyone know why this is happening?



Posts: 105

Location: US

Occupation: Software Engineer

  • Send private message


Thursday, July 13th 2006, 10:32pm

IIRC, there was some bug at some point in time that caused this to happen. The bug is fixed now (i think it was in kdelibs or something like that, can't remember) so you shouldn't have this problem anymore.


Wednesday, October 4th 2006, 9:45pm

I'm not sure what version you are using, but I did not have that same issue of deleting beyond kopeterc. I closed my kopete and removed the offending ID. But yes, this is an annoying bug.