You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, April 20th 2006, 7:01pm

[KOPETE] 0.11.1 crashs when using settings

I am using a fedora core 5 system. The last days the update to KDE 3.5.2 was avaible and installed. However I just want to add a jabber account to kopete and clicked on settings->configure (hope this is correct for the english version) and kopete crashed with the report at the bottom. It looks like an account that already was created is completly operational. However it looks like it is not possible to change anysettings with engaging a crash. I properply guess, that this is not a common bug, cause it should be noticed by anyone else. Deleteing kopeterc and kopete settings doesn't help either. So anyone an idea or another fc5 user that might can confirm this problem?



[KCrash handler]
#6 0x00f134f4 in Kopete::AV::VideoDevice::getBrightness ()
from /usr/lib/
#7 0x00f1ac08 in Kopete::AV::VideoDevicePool::getBrightness ()
from /usr/lib/
#8 0x00c823d9 in AVDeviceConfig::setVideoInputParameters ()
from /usr/lib/kde3/
#9 0x00c83164 in AVDeviceConfig::AVDeviceConfig ()
from /usr/lib/kde3/
#10 0x00c8377f in KGenericFactory<AVDeviceConfig, QWidget>::createObject ()
from /usr/lib/kde3/
#11 0x06460501 in KLibFactory::create () from /usr/lib/
#12 0x0067a122 in KCModuleLoader::load () from /usr/lib/
#13 0x0067a937 in KCModuleLoader::loadModule () from /usr/lib/
#14 0x0067b0d0 in KCModuleProxy::realModule () from /usr/lib/
#15 0x0067cf72 in KCModuleProxy::buttons () from /usr/lib/
#16 0x0067d013 in KCMultiDialog::slotAboutToShow ()
from /usr/lib/
#17 0x0067d1f8 in KCMultiDialog::qt_invoke () from /usr/lib/
#18 0x04da72aa in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/
#19 0x00a10eb4 in KDialogBase::aboutToShowPage () from /usr/lib/
#20 0x0067ff2b in KCMultiDialog::addModule () from /usr/lib/
#21 0x0068dd0d in KSettings::PageNode::addToDialog ()
from /usr/lib/
#22 0x0068dbd2 in KSettings::PageNode::addToDialog ()
from /usr/lib/
#23 0x00689662 in KSettings::Dialog::createDialogFromServices ()
from /usr/lib/
#24 0x00689878 in KSettings::Dialog::show () from /usr/lib/
#25 0x05b5c100 in KopetePreferencesAction::slotShowPreferences ()
from /usr/lib/
#26 0x05b5c1b2 in KopetePreferencesAction::qt_invoke ()
from /usr/lib/
#27 0x04da72aa in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/
#28 0x04da7c3d in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/
#29 0x009d6ef9 in KAction::activated () from /usr/lib/
#30 0x00a17392 in KAction::slotActivated () from /usr/lib/
#31 0x00afd5dd in KAction::slotPopupActivated () from /usr/lib/
#32 0x00afd8a1 in KAction::qt_invoke () from /usr/lib/
#33 0x05b5c1d7 in KopetePreferencesAction::qt_invoke ()
from /usr/lib/
#34 0x04da72aa in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/
#35 0x0513069e in QSignal::signal () from /usr/lib/qt-3.3/lib/
#36 0x04dc56c7 in QSignal::activate () from /usr/lib/qt-3.3/lib/
#37 0x04ec2c35 in QPopupMenu::mouseReleaseEvent ()
from /usr/lib/qt-3.3/lib/
#38 0x009e238e in KPopupMenu::mouseReleaseEvent () from /usr/lib/
#39 0x04de3665 in QWidget::event () from /usr/lib/qt-3.3/lib/
#40 0x04d3ea1b in QApplication::internalNotify ()
from /usr/lib/qt-3.3/lib/
#41 0x04d4021a in QApplication::notify ()
from /usr/lib/qt-3.3/lib/
#42 0x06530393 in KApplication::notify () from /usr/lib/
#43 0x04cd6ffc in QETWidget::translateMouseEvent ()
from /usr/lib/qt-3.3/lib/
#44 0x04cd514f in QApplication::x11ProcessEvent ()
from /usr/lib/qt-3.3/lib/
#45 0x04ce707b in QEventLoop::processEvents ()
from /usr/lib/qt-3.3/lib/
#46 0x04d58135 in QEventLoop::enterLoop ()
from /usr/lib/qt-3.3/lib/
#47 0x04d57fde in QEventLoop::exec () from /usr/lib/qt-3.3/lib/
#48 0x04d3e65f in QApplication::exec () from /usr/lib/qt-3.3/lib/
#49 0x0806d6c4 in ?? ()
#50 0x001167e4 in __libc_start_main () from /lib/
#51 0x0806cf81 in ?? ()


Thursday, April 20th 2006, 9:13pm

I recommend upgrading to 0.12beta2, as there have been a lot of improvements.
I also remember some people reporting issues with the configuration dialogue on Kopete's mailing list, these issues have been fixed, as far as I know.


Friday, April 21st 2006, 2:33pm

I just compiled and installed the beta2 and it looks like the problem is also present there. If I try to configure kopete, it crashs. I compiled with enable-debug=full and however this time this is shown on the console: "lt-kopete: symbol lookup error: /usr/lib/kde3/ undefined symbol: _ZN6Kopete2AV15VideoDevicePool21fillStandardKComboBoxEP9KComboBox"

Looks like it's poiting (like the other problem) to the av-device. What's kopete trying here?



Posts: 948

Location: Eindhoven

Occupation: Software Engineer

  • Send private message


Friday, April 21st 2006, 2:38pm

Does a ldconfig do the trick? Seems like the newer installed libraries from Kopete are looking into some old libraries.
Bram Schoenmakers
KDE Netherlands (



Posts: 1

Location: San Diego, CA

Occupation: Web app developer, sys admin

  • Send private message


Monday, April 24th 2006, 8:41pm

FWIW I get the same error as the original poster. I'm running FC4 and using Kopete 0.11.1. I just did a yum update last night (including a kernel update), and today Kopete crashes every time I try to go into Settings > Configure... everything else on the system appears to be working the same as always though.

I tried running an ldconfig, but no joy. It still crashes with the same error as before.

Update: I manually installed 0.12 Beta 2, and it appears to have fixed the problem.

This post has been edited 1 times, last edit by "brucet" (Apr 24th 2006, 9:37pm)



Posts: 105

Location: US

Occupation: Software Engineer

  • Send private message


Wednesday, April 26th 2006, 10:32pm

did you install kopete before trying to run it? if not, install it first, then run it.