You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Tuesday, January 10th 2006, 9:24pm

K-menu configuration

Hello all,

I'm having a problem with the K-menu under SuSE 10.0. I tried upgrading to KDE 3.5 but had to revert as it was causing stability problems. I now have an annoying situation: whereas previously the K-menu would not create a sub-menu for a "Description" if only one program existed, now all programs reside in sub-menus for their given function.

e.g. whereas previously the archiving tool Ark could be reached just by Utilities -> Archiving tool, now I have to go through Utilities -> Archiving -> Archiving tool.

Or, for a spreadsheet, instead of Office -> Spreadsheet, I have to go, Office -> Spreadsheet -> Spreadsheet.

Any idea how I can get the menu to go back to the simpler configuration that it had when SuSE 10.0 was first installed?

Many thanks,

-- Joe


Wednesday, January 11th 2006, 11:16am

You can simply remove your /home/<my_user>/.kde folder. Restart your kde session, this will recreate the folder with default options. However, all your custom settings will be lost.


Thursday, January 12th 2006, 5:15pm

Thanks very much. Is there any way of just deleting the part of the .kde settings that relate to the menu appearance? I'd rather not delete all my KDE settings if I can avoid it. :P

-- Joe


Friday, January 13th 2006, 12:46pm

I never tried that, I'm not even sure if a partial recreation of the folder is possible. It sure could be done manually, by copying some files from the kde templates. Anyways, a quick glance inside the .kde folder showed that there's no dedicated file for it, so I have no idea where to begin with... can't help here, sorry.