You are not logged in.


Friday, December 16th 2005, 11:14pm

webcam invitation options?

I'm sure I'm missing something really obvious here. I can find the Settings->Configure->Devices route to the webcam setup window, where I see my webcam image just fine. I can also request someone else's webcam, and see it, via the little webcam picture on the top of the chat window.

However, I can see no way of starting (broadcasting) or offering my webcam to a particular user. I've looked through the docs and am unable to find an explanation or reference either. Any hints appreciated.

I'm using SuSe 10 with this version of kopete:
Qt: 3.3.5
KDE: 3.5.0 Level "a"
Kopete: 0.11


ps. well done for getting webcams to work with yahoo and suse :-)


Monday, December 19th 2005, 11:49am

RE: webcam invitation options?

So, it seems this can be done, but only if you use a later (development) version of kopete, where the newer libraries use yahoo_rewrite->yahookwrite. I tried to install this using the instructions supplied on this website:

The update failed right down at the make level with missing files. Although the configure was successful, the make failed with no prefix found, even though I passed the --prefix arg correctly:


This is very frustrating, if someone can get a bit further than me, or can offer any helpful suggestions, I'd be pleased to hear about it.



Monday, December 19th 2005, 5:49pm

Explicitly setting KDEDIR and KDEDIRS (both) to '/opt/kde3' is getting a bit further, make gives this error now:

/usr/lib/gcc/i586-suse-linux/4.0.2/../../../../i586-suse-linux/bin/ld: cannot find -lacl
collect2: ld returned 1 exit status
make[2]: *** [] Error 1

Showing my ignorance now, anyone know what '-lacl' is, and (more importantly) how I fix the Error?



Monday, December 19th 2005, 9:30pm

So, finally, I managed to locate and install the missing libacl-devel and libatt-devel packages (not included with the SuSe 10 CDs BTW). AND make worked - wahoo!

Now I'm running (the updated version I guess):
$> kopete -v
Qt: 3.3.5
KDE: 3.5.0 Level "a"
Kopete: 0.11

and the original kopete (3.4) looks a bit different to the new one:

$> l kopete*
-rwxr-xr-x 1 root root 3766010 2005-12-19 19:27 /opt/kde3/bin/kopete*
-rwxr-xr-x 1 root root 770948 2005-12-12 12:18 /opt/kde3/bin/kopete-3.4*

But I still see no way of sending a cam image, or offering one to a user...

Am I still missing something very basic here?



Tuesday, December 20th 2005, 8:15am

Hmmm, kopete versions appear to be curiously identical, although the files are different - that looks suspicious...



Wednesday, December 21st 2005, 2:24pm


i've been wondering the same thing for a long time now. i'm on gentoo, which i've been very happy with for the most part. unfortunately, i can't get php to emerge properly (because a certain dep doesn't emerge properly) so i can't emerge subversion, so i can't follow the instructions at . seems like even if i could follow them, i still wouldn't be able to broadcast from my webcam...

it's all very frustrating. i bought a new linux-compatible webcam just so i could use it with kopete and talk to my friend who lives in a different state. i've tried other chat programs that are supposed to support webcams but they all either don't install properly, or they just suck.

i hope someone fixes this soon. i would be overwhelmed with joy.



Posts: 5

Location: Europe.Poland.Zabrze

Occupation: ~student

  • Send private message


Thursday, December 29th 2005, 11:57pm

that's my problem too :/
ska ska ska