You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.



  • "munkie_poo" started this thread

Posts: 9

Location: Newcastle, UK

  • Send private message


Tuesday, December 13th 2005, 2:55am

[kopete] webcam works but doesnt

In kopete my webcam works but the image is all over the place, it 'looks' like a resolution problem (but Ive no idea). Ive hopefully attached an image.

Im running Slack 10.2 (2.6.13) + Kde 3.5 and my cam is a cheapie thing which runs using the 'stv680' module.

Source code

Bus 003 Device 002: ID 0553:0202 STMicroelectronics Imaging Division (VLSI Vision) Aiptek PenCam 1

The cam works fine in xawtv.
munkie_poo has attached the following image:
  • kopete.jpg

This post has been edited 1 times, last edit by "munkie_poo" (Dec 14th 2005, 7:31pm)



Posts: 1

Location: rsn

Occupation: hvac engineering

  • Send private message


Tuesday, December 13th 2005, 6:34pm

RE: [kopete] webcam works but doesnt

I've tried it too, got the same problem as you.
In kopete, the preview screen is all garbled.
The webcam works in other apps though.

The whole bunch runs on 2.6.14-gentoo-r2 x86_64.


Wednesday, December 14th 2005, 7:10pm

RE: [kopete] webcam works but doesnt

My problem is the same. I'm using the 'ov511' module and my webcam works fine in xawtv and vlc. But the webcam does not work in kopete. In the settings dialog I always get a black image or some green and red points on black background. I'm running a 2.6.13 kernel (SUSE 10.0) and KDE 3.5. I've compiled kopete from the latest svn-sources. Any hint would be great!


Sunday, January 15th 2006, 11:38am

I have the same problem with my WebCam Philips toucam II PCVC 820K, using the ov511 driver. It works with xawtv, amsn, gnomemeeting, but not with kopete and camorama...


Saturday, January 21st 2006, 6:38pm

I found one problem with the ov511 driver. Namely, it expects only valid picture size arguments and does not compensate for too large or too small values, as expected by Kopete.

Here is a patch against version 2.30 of the driver. It fixes a problem for ov518-based webcams, so people with ov511 webcams may need to do a similar hack in ov511_mode_init_regs:

--- ov511-2.30/ov511_core.c 2005-10-22 04:27:18.000000000 -0400
+++ ov511-new/ov511_core.c 2006-01-18 15:42:36.000000000 -0500
@@ -2395,7 +2395,7 @@
ov518_mode_init_regs(struct usb_ov511 *ov,
int width, int height, int mode, int sub_flag)
- int hsegs, vsegs, hi_res;
+ int hsegs, vsegs, hi_res, newwidth, newheight;

if (sub_flag) {
width = ov->subw;
@@ -2405,14 +2405,28 @@
PDEBUG(3, "width:%d, height:%d, mode:%d, sub:%d",
width, height, mode, sub_flag);

- if (width % 16 || height % 8) {
- err("Invalid size (%d, %d)", width, height);
- return -EINVAL;
- }
+ /* Fix width and height according to the maximum and minimum values.
+ The newwidth and newheight variables are only used to get a debug
+ message in case any of the two values is changed. */
+ if (width < ov->minwidth)
+ newwidth = ov->minwidth;
+ else if (width > ov->maxwidth)
+ newwidth = ov->maxwidth;
+ else
+ newwidth = width;

- if (width < ov->minwidth || height < ov->minheight) {
- err("Requested dimensions are too small");
- return -EINVAL;
+ if (height < ov->minheight)
+ newheight = ov->minheight;
+ else if (height > ov->maxheight)
+ newheight = ov->maxheight;
+ else
+ newheight = height;
+ if (width != newwidth || height != newheight) {
+ width = newwidth;
+ height = newheight;
+ PDEBUG(3, "new width:%d, new height:%d, mode:%d, sub:%d",
+ width, height, mode, sub_flag);

if (width >= 320 && height >= 240) {


Sunday, January 22nd 2006, 6:35pm

short instruction

Sounds great! I would really like to add webam support for my webcam chipset. Could you please post a short instruction how to use your patch? Would be great! Thanks.


Sunday, January 22nd 2006, 8:49pm

RE: short instruction

Download ov511-2.30 from this location:…11-2.30.tar.bz2

Extract the files in the downloaded archive. Copy the patch to a file (e.g., named ov511_fix_size.patch) inside the 0v511-2.30 directory. Then issue the command

patch -p1 < ov511_fix_size.patch

inside this directory. The code is now patched. Run 'make' and 'make install' (as root), and your new driver is ready to go.



Monday, January 23rd 2006, 11:24am


The given command results in the following error:

patching file ov511_core.c
patch: **** malformed patch at line 4: ov518_mode_init_regs(struct usb_ov511 *ov,

Any idea what to do about it?


Monday, January 23rd 2006, 2:37pm

RE: instruction

Yes, I shouldn't have posted a patch as message text. I attach the patch file, which also includes the same fix to the ov511 chipset.

elahav has attached the following file:


Monday, January 23rd 2006, 5:21pm

Thank you, patching now works without any problem. But still, my webcam does not work for kopete. The patched module still works for xawtv, but kopete simply outputs "read error 14". I guess I'll have to wait for some more changes to finally have my webcam supported in kopete.
Nevertheless,thank you for your support!

This post has been edited 1 times, last edit by "bauerfichtner" (Jan 23rd 2006, 5:21pm)


Wednesday, January 25th 2006, 8:47pm

I have a OV511 cam and I got it to work with Kopete by loading the driver with v4l2 support enabled. So when you insert the driver:

Source code

# modprobe ov511 v4l2=1

By the way, I applied the patch mentioned earlier in this thread before attempting this, so I'm not sure if that's part of the solution as well. But thanks anyway. :)

And oh yeah, the controls (brightness and stuff) don't seem to work and setting that to auto doesn't make any difference as far as I can see. Is that normal behaviour for all webcams atm or just this one?

This post has been edited 1 times, last edit by "snader" (Jan 25th 2006, 8:50pm)


Thursday, January 26th 2006, 9:05am

webcam works ... almost

Seems as if enabling v4l2 is working (take a look at the picture). Nevertheless, sending my webcam via MSN is not working. For testing purposes I made myself a second account. But when I try to send my webcam, I always get an error message (take a look at the second picture).

I guess it'll be some more testing and wating.
Anyway, thank you for your help.
bauerfichtner has attached the following images:
  • webcam_works.png
  • no_image.png


Thursday, January 26th 2006, 9:11am

Okay, well I got it to work a few times. ;-) But it seems that if the other side opens a chat window to someone else as well, the session gets terminated (it says "user xxx has left the chat" in the chat window). Oh yeah and it only works if I invite someone to watch, not the other way around.

By the way, the "other side" was using the "real" MSN client.

This post has been edited 1 times, last edit by "snader" (Jan 26th 2006, 9:12am)


Thursday, January 26th 2006, 9:42am

Perhaps it's not not working because of any problem with kopete or the webcam, but because of my internet connection. I have to use a NAT-gateway, which forwards on nearly all ports. At least, the responsible admin tells me. But already some times before I've had the impression that this is not the very truth. There seem to be some restrictions, I guess I'll have to get in touch with the admin.


Thursday, March 2nd 2006, 5:41pm

I finally managed to set up a second PC, which is now running win32. Sending my webcam works fine, as long as I use the original MSN-client with this second PC. Sending my webcam via Yahoo! works, but only partially. The received image is strangely grey, I have no idea what the reason could be.

When starting a second instance of kopete on my linux box, sending the webcam via MSN fails ("no image received"), but sending it via Yahoo! results in a perfect image.

Has anyone got an idea what could be done to receive webcam via MSN? Yes, I opened up port 6891 for incoming webcam connection.

Thanks in advance.



Posts: 105

Location: US

Occupation: Software Engineer

  • Send private message


Thursday, March 2nd 2006, 10:49pm

Make sure port 6891 is forwarded to the right place.

Which version of the official MSN client are you using when attempting to receive the webcam image in Kopete?

Depending on how up to date your svn checkout is, there could be more fixes to the video code that could help, especially with the partially gray images. (unless the gray images come from the original yahoo client)


Friday, March 3rd 2006, 9:30am

I am using the latest MSN-client, which is 7.0. And my svn checkout is done every few days.

I will do some more testing and report new results, if there are any.


Friday, March 3rd 2006, 11:30am

Well, as announced, I did some more testing, here are the results:

1) Sending my webcam from kopete to MSN Messenger 7.0 works properly, there are no problems, the image is of acceptable quality.
2) Sending my webcam from MSN Messenger 7.0 to kopete works fine. (I guess it was a driver problem for my webcam with win32, I reinstalled it). Take a look at the first picture.
3) Sending my webcam from kopete to the original Yahoo! client works well, but (as mentioned before), the picture is somewhat grey (sorry, no screenshot available).
4) Sending my webcam from the original Yahoo! client to kopete does not work. There appears a popup, asking if I want to accept the invitation, but nothing happens, if I accept. This might be due to my webcam and the original Yahoo! client, as I do not even have a preview with it, only a black window (but it's working with MSN Messenger 7.0!).
5) Sending my webcam from kopete to kopete via MSN does not work for me. I get the well known popup, I accept, and then nothing happens, I do not even get an "no webcam image received".
6) Sending my webcam from kopete to kopete via Yahoo! works sometimes, sometimes it doesn't. If it doesn't, I send the webcam once again, accept it again and it works fine. Take a look at the second picture.

What I could not test is sending and receiving at the same time, as I have no second webcam. And there's no difference in opening port 6891 or not and specifying it in kopete or not, by the way. So, it seems as there has not been a problem with the connection.
bauerfichtner has attached the following images:
  • webcam_working1.jpg
  • webcam_working5_yahoo.jpg


Saturday, March 4th 2006, 4:23pm

I do not understand this OS win32. Today I spent some more time on sending my webcam via Yahoo!. And today it worked. I had a preview of my webcam in the Yahoo! client and I was able to send my webcam from the original Yahoo! client to kopete without problems. The image is of acceptable quality.

So, it seems as if averythins is working (at least some times it did work), except sending the webcam from kopete to kopete via MSN. Any hints? What could be the reason?


Saturday, January 20th 2007, 1:11pm

patch still works with ov511 version 2.32 8)

Just wanted to report that the patch still works with the (at the moment) newest version of ov511 (2.32).
Everything is fine here. I hoped it would also fix the camorama problem (black screen) ... unfortunately it doesn't. But it's anyway great to have Kopete finally fully functional. 8)