You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Friday, June 10th 2005, 2:02pm

KDE: Inter-process authentication problems

I'm having trouble with inter-process authentication in KDE 3.4 on Kanotix (although I've seen it on other distros, too).

Here are the symptoms:

- Sometimes (no rhyme or reason) when I kdesu, I receive an error saying, "Unable to enable inter-process communications for KDE. Authentication Rejected, reason: Non of the authentication protocols specified are supported and host-based authentication failed."

- I am unable to access "Administrator Mode" in any of the kcontrol modules

- When I run Konqueror in root-mode in my user account, I stumble across errors and problems starting processes. For instance, I *sometimes* cannot type "media:/" in the location bar, because the media service is not running. But it works find in my user account (and it worked fine just now in a root-mode konqueror, as I tried to get the error message syntax).

I've tried deleting the .ICEauthority file in my user account, but this did no good. Any other ideas?


Saturday, June 11th 2005, 4:49am

RE: KDE: Inter-process authentication problems

Replying to my own post here for the sake of documentation...

Apparently something got hosed in my user account. I simply logged out and logged in as root, changed the password on the user account, and all was well. I was even able to change it back to the original password after logging in once with the new password.

Just another testimonial as to why running as root is a bad idea. If I'd not had a clean root account, I would not have been able to fix this.



Posts: 1,273

Location: Graz, Austria

Occupation: Software Developer

  • Send private message


Saturday, June 11th 2005, 1:13pm

RE: KDE: Inter-process authentication problems


Originally posted by elempoimen
Replying to my own post here for the sake of documentation...
If I'd not had a clean root account, I would not have been able to fix this.

Unless you are really thoughtless when working as root (i.e. putting exit into root's .bashrc or using /bin/false as the shell for root), it is very unlikely you can disable the root account.

Qt/KDE Developer
Debian User


Saturday, June 11th 2005, 2:45pm

RE: KDE: Inter-process authentication problems

Disable? No.

Break? Yes.

Note that I didn't disable my user account. There simply was an authentication problem within KDE related to my user account. Granted, the root account cannot have authentication problems, per se...but things can go wierd sometimes.

Bottom line: in my experience, I've been glad I've not run as root at least a few times. I'd recommend it to all my users. And I'd especially recommend it on less safe OS environments (like Windoze--true, no actual "root" account there, but damage can be more controlled by not running as "Administrator")