You are not logged in.

Dear visitor, welcome to If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Monday, May 16th 2005, 1:55pm

kde unable to handle files with international characters

today i had one of the best laughs ...

I am german and live currently in Japan. My KDE/Debian system is set to english default.
I set my girlfriends kde desktop to completely japanese, mine is still english.

Well first i want to say, that i have not found a japanese font with which the desktop is usable, even after switching her desktop to english it looks extremely crappy. But she is using the computer just to read her emails and chat every once in a while, so i dont really care.

The real issue is, i have a couple of sound files with japanese names on my ntfs mount, kde cannot read them (even though i am able to access them via shell). I guess thats caused by the whole euc/shift jis issue, so thats understandable.
But i also have a couple of sound files with german names and sometimes they contain those funny chars with dots over them like 'ä'. I copied an archive that i made from my itunes folder to my homefolder and extracted it via ark.
Afterwards i had a directory with name 'Foppt den Dämon'. And konquerer shows that as a locked folder. If i try to click it i get 'Foppt den Dämon does not seem to exist anymore'.
If i try to read it into a mediaplayer (naotun, juk ...) it just simply ignores every file with an umlaut in the name.
If i right click on the directory->properties i get the name clearly written and under size '... does not seem to exist anymore.
Now i got curios with those things, since i have no problems whatsoever via shell, and kde obviously seem to 'understand' the name and is able to display it correctly.
So i created a folder with a japanese name. No problems, can read and access it. Next i tried to create a folder with a german name. Since i have not enabled a german keyboard, i copied the name from the properties window. The new folder name suddenly had a funny '?' instead of that 'ä', but i could access the directory. when i tried to delete the folder i got
'want to delete Foppt den D%3Fmon?'

I dont know what causes this problem, i just think it is extremely funny.
This is the kind of stuff i encountered countless times while using kde. I dont even try to solve problems anymore, since i simply dont have 20*10minutes per day to spare.

Dont misunderstand me, this is not a flame, i like kde. I really love it, and i think it has great potential. It just reminds me sometimes of the early days of windows95 (just the w95 gui, not the numerous other bugs related to the os)