You are not logged in.

1

Wednesday, May 4th 2005, 7:40pm

[Kopete] cant kompile -- have qt-3.0.5

when i try to compile kopete-0.9.2

i only get as far as
./configure --prefix /scratch1/peter/opt
[....]
checking for Qt... configure: error: Qt (>= Qt 3.2) (library qt-mt) not found. Please check your ins
tallation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

after i found this

ls -ld /usr/lib/qt*
drwxr-xr-x 5 root root 4096 Okt 1 2002 /usr/lib/qt-2.3.1
drwxr-xr-x 8 root root 4096 Okt 1 2002 /usr/lib/qt-3.0.5
lrwxrwxrwx 1 root root 8 Feb 16 2003 /usr/lib/qt2 -> qt-2.3.1
lrwxrwxrwx 1 root root 8 Feb 16 2003 /usr/lib/qt3 -> qt-3.0.5
lrwxrwxrwx 1 root root 8 Feb 16 2003 /usr/lib/qt3-gcc3.2 -> qt-3.0.5


i assumed that my qt- thing is too old and tried an older kopete
i tried kopete-0.8.0

and i got again

./configure --prefix /scratch1/peter/opt
[...]
checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not found. Please check your installation!


so i tried kopete-0.7.5 where

./configure --prefix /scratch1/peter/opt
[...]
Good - your configure finished. Start make now

finished fine

but then it stopped at
make
[...]
/bin/sh ../../../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -DKDE_NO_COMPAT -DQT_NO_COMPAT -DQT_NO_CAST_ASCII -DQT_NO_ASCII_CAST -I../../../kopete/libkopete -I../../../kopete/libkopete/ui -I../../../kopete/libkopete/ui -I../../../kopete/libkopete/compat -I/usr/include/kde -I/usr/lib/qt3-gcc3.2/include -I/usr/X11R6/include -I/usr/include/libxml2 -I/usr/include/libxml2 -DQT_THREAD_SUPPORT -D_REENTRANT -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -c -o kopeteemoticons.lo `test -f 'kopeteemoticons.cpp' || echo './'`kopeteemoticons.cpp
kopeteemoticons.cpp: In static member function `static QString
KopeteEmoticons::parseEmoticons(QString)':
kopeteemoticons.cpp:244: no method `QRegExp::escape'
make[4]: *** [kopeteemoticons.lo] Fehler 1


any ideas how i can get kopete to work

jacek

Trainee

Posts: 105

Location: Warsaw, Poland

Occupation: Student

  • Send private message

2

Wednesday, May 4th 2005, 8:19pm

RE: [Kopete] cant kompile -- have qt-3.0.5

Maybe you should upgrade the Qt library?

3

Thursday, May 5th 2005, 6:24pm

RE: [Kopete] cant kompile -- have qt-3.0.5

yeah i only hoped i could avoid that,
i dont have root access on that machine and i wasent so sure how peacefully different qt versions would live together (or how kde would react)

Christian

Beginner

Posts: 26

Location: Karlsruhe, Germany

Occupation: in training

  • Send private message

4

Thursday, May 5th 2005, 6:28pm

You dont need root access to compile Qt.
"You shouldn't learn Qt and be a logical thinking person, but learn Qt to become such" (decoding)
"A C++ compiler is not a baby rattle." (Kevin)